summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD29
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..111cbf51305c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by makepkg 4.2.1
+# Sun Apr 12 19:33:40 UTC 2015
+pkgbase = lib32-gtkmm
+ pkgdesc = C++ bindings for gtk2 (32 bit, library only)
+ pkgver = 2.24.4
+ pkgrel = 1
+ url = http://gtkmm.sourceforge.net/
+ arch = x86_64
+ license = LGPL
+ makedepends = gcc-multilib
+ depends = lib32-gtk2
+ depends = lib32-pangomm
+ depends = lib32-atkmm
+ depends = gtkmm
+ options = !libtool
+ options = !emptydirs
+ source = http://ftp.gnome.org/pub/GNOME/sources/gtkmm/2.24/gtkmm-2.24.4.tar.xz
+ sha256sums = 443a2ff3fcb42a915609f1779000390c640a6d7fd19ad8816e6161053696f5ee
+
+pkgname = lib32-gtkmm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d601fc345f31
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Gicu Gorodenco <cyclopsihus 'at' gmail 'dot' com>
+# Contributor: josephgbr
+_pkgbasename=gtkmm
+pkgname=lib32-$_pkgbasename
+pkgver=2.24.4
+pkgrel=1
+pkgdesc="C++ bindings for gtk2 (32 bit, library only)"
+arch=('x86_64')
+url="http://gtkmm.sourceforge.net/"
+license=('LGPL')
+depends=('lib32-gtk2' 'lib32-pangomm' 'lib32-atkmm' "${_pkgbasename}")
+makedepends=('gcc-multilib')
+options=('!libtool' '!emptydirs')
+source=(http://ftp.gnome.org/pub/GNOME/sources/${_pkgbasename}/2.24/${_pkgbasename}-${pkgver}.tar.xz)
+sha256sums=('443a2ff3fcb42a915609f1779000390c640a6d7fd19ad8816e6161053696f5ee')
+
+build() {
+ cd "${srcdir}/${_pkgbasename}-${pkgver}"
+ ./configure --prefix=/usr --libdir=/usr/lib32 CXX='g++ -m32'
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgbasename}-${pkgver}"
+ sed -i -e 's/^doc_subdirs/#doc_subdirs/' Makefile
+ make DESTDIR="${pkgdir}" install
+ # Cleanup for a lib32 package
+ rm -rf ${pkgdir}/usr/include
+}