summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e79c8daefeb2..db5b402de6be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lib32-libsrtp
pkgdesc = Library for SRTP (Secure Realtime Transport Protocol) (32-bit)
- pkgver = 2.4.2
+ pkgver = 2.5.0
pkgrel = 1
epoch = 1
url = https://github.com/cisco/libsrtp
@@ -13,7 +13,7 @@ pkgbase = lib32-libsrtp
depends = lib32-glibc
depends = lib32-nss
depends = libsrtp
- source = git+https://github.com/cisco/libsrtp#commit=90d05bf8980d16e4ac3f16c19b77e296c4bc207b
+ source = git+https://github.com/cisco/libsrtp#commit=a566a9cfcd619e8327784aa7cff4a1276dc1e895
sha256sums = SKIP
pkgname = lib32-libsrtp
diff --git a/PKGBUILD b/PKGBUILD
index 379471d0dbc6..0a4638feb025 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_basename=libsrtp
pkgname=lib32-libsrtp
-pkgver=2.4.2
+pkgver=2.5.0
pkgrel=1
epoch=1
pkgdesc="Library for SRTP (Secure Realtime Transport Protocol) (32-bit)"
@@ -13,14 +13,14 @@ license=(BSD)
depends=('lib32-glibc' 'lib32-nss' 'libsrtp')
makedepends=('git' 'lib32-libpcap' 'meson')
checkdepends=('procps-ng')
-_commit=90d05bf8980d16e4ac3f16c19b77e296c4bc207b # tags/v2.4.2
+_commit=a566a9cfcd619e8327784aa7cff4a1276dc1e895 # tags/v2
source=("git+https://github.com/cisco/libsrtp#commit=$_commit")
sha256sums=('SKIP')
pkgver() {
cd $_basename
- git describe --tags | sed 's/^v//;s/-/+/g'
+ git describe --tags | sed 's/^v//;s/[^-]*-g/r&/;s/-/+/g'
}
prepare() {
@@ -36,12 +36,16 @@ build() {
export CXX='g++ -m32'
export PKG_CONFIG='/usr/bin/i686-pc-linux-gnu-pkg-config'
- arch-meson $_basename build \
+ local meson_options=(
--libdir=lib32 \
--buildtype release \
-D crypto-library=nss \
-D crypto-library-kdf=disabled \
-D doc=disabled
+ )
+
+ arch-meson libsrtp build "${meson_options[@]}"
+
meson compile -C build
}