summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD12
-rw-r--r--configure.patch20
3 files changed, 11 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b844bed465bd..027bc84fcdf7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = lib32-zbar
pkgdesc = Application and library for reading bar codes from various sources. 32bit libraries only version
- pkgver = 0.23.1
- pkgrel = 3
- url = https://github.com/procxx/zbar
+ pkgver = 0.23.90
+ pkgrel = 1
+ url = https://github.com/mchehab/zbar
arch = x86_64
license = LGPL
makedepends = docbook-xsl
@@ -12,10 +12,7 @@ pkgbase = lib32-zbar
depends = lib32-dbus
depends = lib32-libsm
depends = lib32-libxv
- source = zbar-0.23.1.tar.gz::https://github.com/mchehab/zbar/archive/0.23.1.tar.gz
- source = configure.patch
- sha256sums = 297439f8859089d2248f55ab95b2a90bba35687975365385c87364c77fdb19f3
- sha256sums = 4b6bd83d5923aed8ac34ff088340a65514bcff0a345dc6acd08e348e72744702
+ source = zbar-0.23.90.tar.gz::https://github.com/mchehab/zbar/archive/0.23.90.tar.gz
+ sha256sums = 25fdd6726d5c4c6f95c95d37591bfbb2dde63d13d0b10cb1350923ea8b11963b
pkgname = lib32-zbar
-
diff --git a/PKGBUILD b/PKGBUILD
index ab04890e3136..f717a20015f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,19 +6,19 @@
# Mantainer: Lorenzo Ferrillo <lorenzofer at live dot it>
_pkgname=zbar
pkgname=lib32-zbar
-pkgver=0.23.1
-pkgrel=3
+pkgver=0.23.90
+pkgrel=1
pkgdesc="Application and library for reading bar codes from various sources. 32bit libraries only version"
arch=('x86_64')
-url="https://github.com/procxx/zbar"
+url="https://github.com/mchehab/zbar"
license=('LGPL')
depends=('zbar' 'lib32-v4l-utils' 'lib32-dbus' 'lib32-libsm' 'lib32-libxv')
makedepends=('docbook-xsl' 'xmlto')
-source=("$_pkgname-$pkgver.tar.gz::https://github.com/mchehab/zbar/archive/$pkgver.tar.gz" "configure.patch")
-sha256sums=('297439f8859089d2248f55ab95b2a90bba35687975365385c87364c77fdb19f3' '4b6bd83d5923aed8ac34ff088340a65514bcff0a345dc6acd08e348e72744702')
+source=("$_pkgname-$pkgver.tar.gz::https://github.com/mchehab/zbar/archive/$pkgver.tar.gz")
+sha256sums=('25fdd6726d5c4c6f95c95d37591bfbb2dde63d13d0b10cb1350923ea8b11963b')
prepare() {
cd zbar-$pkgver
- patch -i ${srcdir}/configure.patch configure.ac
+# patch -i ${srcdir}/configure.patch configure.ac
autoreconf -vfi
}
diff --git a/configure.patch b/configure.patch
deleted file mode 100644
index 2bf6271e618f..000000000000
--- a/configure.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/zbar-0.23.1/configure.ac.old 2020-04-20 23:09:21.000000000 +0200
-+++ src/zbar-0.23.1/configure.ac 2021-01-17 16:31:29.409104475 +0100
-@@ -656,7 +656,7 @@
- [with_qt="no"])])])
-
- AS_IF([test "x$with_qt" != "xno"],
-- AS_IF([test "x$with_qt5" != "xno"],
-+ [AS_IF([test "x$with_qt5" != "xno"],
- [AC_CHECK_PROGS(MOC, [moc-qt5 moc])
- AC_MSG_NOTICE([using moc from $MOC])
- QT_VERSION=`$PKG_CONFIG Qt5Gui --modversion`
-@@ -672,7 +672,7 @@
- QT_VERSION=`$PKG_CONFIG QtGui --modversion`
- AC_MSG_NOTICE([using Qt version $QT_VERSION])
- qt_pkgconfig_file="zbar-qt.pc"
-- ]))
-+ ])])
-
- AM_CONDITIONAL([HAVE_QT], [test "x$with_qt" = "xyes"])
-