summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--00-missing-include.patch12
-rw-r--r--PKGBUILD29
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e74fd03a603b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = lib45d
+ pkgdesc = 45Drives C++ Library.
+ pkgver = 0.3.6
+ pkgrel = 1
+ url = https://github.com/45Drives/lib45d
+ arch = x86_64
+ license = GPL3
+ makedepends = gcc
+ makedepends = make
+ makedepends = patch
+ depends = glibc
+ source = lib45d-0.3.6.tar.gz::https://github.com/45Drives/lib45d/archive/refs/tags/v0.3.6.tar.gz
+ source = 00-missing-include.patch
+ sha256sums = 76ae1811beffe67025fd72a055dd662496cfbbe4790e2bb68d42980c48cadd02
+ sha256sums = 373b23f23c8d832780484379aedc0c4003d744a6ab433e0d1c85fa91074f7e55
+
+pkgname = lib45d
diff --git a/00-missing-include.patch b/00-missing-include.patch
new file mode 100644
index 000000000000..ef20b08f732d
--- /dev/null
+++ b/00-missing-include.patch
@@ -0,0 +1,12 @@
+# https://github.com/45Drives/lib45d/commit/a607e278182a3184c004c45c215aa22c15d6941d
+diff --git a/src/impl/bytes.cpp b/src/impl/bytes.cpp
+index 9bb4c7c..1dac914 100644
+--- a/src/impl/bytes.cpp
++++ b/src/impl/bytes.cpp
+@@ -22,6 +22,7 @@
+ #include "45d/Exceptions.hpp"
+
+ #include <cmath>
++#include <cstdint>
+ #include <iomanip>
+ #include <regex>
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2428835a917b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Tadeusz Magura-Witkowski <tadeuszmw gmail>
+
+pkgname=lib45d
+pkgver=0.3.6
+pkgrel=1
+pkgdesc="45Drives C++ Library."
+arch=('x86_64')
+url="https://github.com/45Drives/lib45d"
+license=('GPL3')
+makedepends=('gcc' 'make' 'patch')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/45Drives/lib45d/archive/refs/tags/v${pkgver}.tar.gz" "00-missing-include.patch")
+sha256sums=('76ae1811beffe67025fd72a055dd662496cfbbe4790e2bb68d42980c48cadd02'
+ '373b23f23c8d832780484379aedc0c4003d744a6ab433e0d1c85fa91074f7e55')
+depends=('glibc')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ patch --forward --strip=1 --input="${srcdir}/00-missing-include.patch"
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DEVEL=1
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make install DESTDIR="$pkgdir" DEVEL=1
+}