summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e0a4a8a43924..94ef45a91179 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -32,8 +32,12 @@ build()
export PYTHONPATH=$srcdir/langkit-gpl-2018-src:$PYTHONPATH
+ # Clang has trouble compiling the Quex-generated lexer, so make sure
+ # GPRbuild chooses GCC.
+ gprconfig -o config.cgpr --batch --config=c,,,,GCC --config=ada,,,,
+
python2 ada/manage.py generate
- python2 ada/manage.py build
+ python2 ada/manage.py build --gargs="-R --config=$PWD/config.cgpr"
}