summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD31
2 files changed, 33 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6be138c06ec0..a3c4d373de6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,11 +6,12 @@ pkgbase = libarcus-git
arch = i686
arch = x86_64
license = GPL2
- makedepends = git
makedepends = cmake
- makedepends = ninja
makedepends = conan
- depends = python
+ makedepends = cura
+ makedepends = git
+ makedepends = ninja
+ makedepends = python-virtualenv
depends = protobuf
depends = python
provides = arcus
@@ -18,6 +19,8 @@ pkgbase = libarcus-git
conflicts = arcus
conflicts = libarcus
source = git+https://github.com/Ultimaker/libArcus.git
- md5sums = SKIP
+ source = git+https://github.com/ultimaker/conan-config.git
+ b2sums = SKIP
+ b2sums = SKIP
pkgname = libarcus-git
diff --git a/PKGBUILD b/PKGBUILD
index 8ebfe74b6bde..9a84687e8ec4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,10 +8,31 @@ url="https://github.com/Ultimaker/libArcus"
license=('GPL2')
provides=('arcus' 'libarcus')
conflicts=('arcus' 'libarcus')
-depends=('python' 'protobuf' 'python')
-makedepends=('git' 'cmake' 'ninja' 'conan')
-source=('git+https://github.com/Ultimaker/libArcus.git')
-md5sums=('SKIP')
+depends=(
+ 'protobuf'
+ 'python'
+)
+makedepends=(
+ 'cmake'
+ 'conan'
+ 'cura'
+ 'git'
+ 'ninja'
+ 'python-virtualenv'
+)
+source=('git+https://github.com/Ultimaker/libArcus.git'
+ 'git+https://github.com/ultimaker/conan-config.git')
+b2sums=('SKIP'
+ 'SKIP')
+
+prepare() {
+ cd libArcus
+ conan config install ../conan-config
+ conan profile detect --force
+ conan remote remove cura # as the JFrog artifact is behind loginwall, so cura needs to be in makedepends instead
+
+ conan install . --build=missing --update
+}
pkgver() {
cd libArcus
@@ -22,7 +43,7 @@ build() {
mkdir -p libArcus/build
cd libArcus/build
cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_LIBDIR=lib -DBUILD_EXAMPLES=OFF -DCMAKE_INSTALL_PREFIX=/usr ..
- make
+ cmake --build .
}
package() {