summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--libardiscovery-Makefile5
3 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c0f969bf49ae..6cc51e4c7523 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libardiscovery-git
pkgdesc = ARSDK Discovery and Connection Management Layer
pkgver = r423.cb4f019
- pkgrel = 2
+ pkgrel = 3
url = http://developer.parrot.com/
arch = x86_64
license = custom
@@ -18,7 +18,7 @@ pkgbase = libardiscovery-git
source = Config-linux-config.h
source = LICENSE
sha256sums = SKIP
- sha256sums = 0904602bdd8ae1d6b1a5923f2c16512dbdb90acddef0c35b7726831bad533c1c
+ sha256sums = 3c17c6844194cacd47df419cba8c4526285c61526353323a854d865988d97037
sha256sums = 74300421b1799e0a32dc62eeded41b56a756b9c4ba95ad42402373e9ea9c3c44
sha256sums = 3f06925dc6c5ab160f4d021cf570591dec1ea7616439a3c59f0b058d8c45b0a9
sha256sums = 5956b54ef47ad26df51991a4aa7002abdcb524a51b455d040f55b4d11a4f44a7
diff --git a/PKGBUILD b/PKGBUILD
index 082634c8f440..df8d9e97e7f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=libardiscovery-git
pkgver=r423.cb4f019
-pkgrel=2
+pkgrel=3
pkgdesc="ARSDK Discovery and Connection Management Layer"
arch=(x86_64)
url="http://developer.parrot.com/"
@@ -24,7 +24,7 @@ source=('libardiscovery::git+https://github.com/Parrot-Developers/libARDiscovery
'Config-linux-config.h'
'LICENSE')
sha256sums=('SKIP'
- '0904602bdd8ae1d6b1a5923f2c16512dbdb90acddef0c35b7726831bad533c1c'
+ '3c17c6844194cacd47df419cba8c4526285c61526353323a854d865988d97037'
'74300421b1799e0a32dc62eeded41b56a756b9c4ba95ad42402373e9ea9c3c44'
'3f06925dc6c5ab160f4d021cf570591dec1ea7616439a3c59f0b058d8c45b0a9'
'5956b54ef47ad26df51991a4aa7002abdcb524a51b455d040f55b4d11a4f44a7'
diff --git a/libardiscovery-Makefile b/libardiscovery-Makefile
index 635dd156c2cb..383efc132291 100644
--- a/libardiscovery-Makefile
+++ b/libardiscovery-Makefile
@@ -1,6 +1,7 @@
CC = gcc
CFLAGS = -fPIC -Wall -Wextra -O2 -g -IIncludes -DHAVE_CONFIG_H
-LDFLAGS = -shared
+LIBS = -ljson-c -lavahi-client -lavahi-common -larsal -larnetworkal
+LDFLAGS = -shared -Wl,-O1,-as-needed,-no-undefined,-z,relro,-z,now
RM = rm -f
TARGET_LIB = libardiscovery.so
@@ -17,7 +18,7 @@ OBJS = $(SRCS:.c=.o)
all: ${TARGET_LIB}
$(TARGET_LIB): $(OBJS)
- $(CC) ${LDFLAGS} -o $@ $^
+ $(CC) ${LDFLAGS} -o $@ $^ ${LIBS}
$(SRCS:.c=.d):%.d:%.c
$(CC) $(CFLAGS) -MM $< >$@