summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 824fda1e7401..b8a8278988f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,15 @@
pkgbase = libbtc-git
pkgdesc = Tiny Bitcoin Library written in C with bitcointool CLI tool
- pkgver = 0.1
+ pkgver = 0.1.07933995e
pkgrel = 1
url = https://github.com/libbtc/libbtc
arch = x86_64
license = MIT
+ makedepends = git
+ depends = glibc
+ depends = libevent
+ provides = libbtc
+ conflicts = libbtc
source = git+https://github.com/libbtc/libbtc.git
source = https://raw.githubusercontent.com/jahway603/libbtc/master/LICENSE
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 993c2a579c37..d75c7acc99bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,16 @@
pkgname=libbtc-git
_pkgname=libbtc
-_commit=07933995e
-pkgver=0.1
+pkgver=0.1.07933995e
pkgrel=1
pkgdesc='Tiny Bitcoin Library written in C with bitcointool CLI tool'
url='https://github.com/libbtc/libbtc'
arch=('x86_64')
license=('MIT')
+makedepends=('git')
+depends=('glibc' 'libevent')
+provides=('libbtc')
+conflicts=('libbtc')
source=("git+$url.git"
"https://raw.githubusercontent.com/jahway603/libbtc/master/LICENSE")
sha256sums=('SKIP'
@@ -16,8 +19,6 @@ sha256sums=('SKIP'
build() {
cd ${_pkgname}
- git checkout ${_commit}
- echo "this will take some time so be patient..."
echo "starting autogen..."
./autogen.sh
echo "starting configure..."