summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD47
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4efab7311a62
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libcec-git
+ pkgdesc = Pulse-Eight's libcec for the Pulse-Eight USB-CEC adapter
+ pkgver = 20120126
+ pkgrel = 1
+ url = https://github.com/Pulse-Eight/libcec
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = udev>=151
+ provides = libcec
+ conflicts = libcec
+ options = !libtool
+
+pkgname = libcec-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9be4083ac0ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Cedric Girard <girard.cedric@gmail.com>
+
+pkgname=libcec-git
+pkgver=20120126
+pkgrel=1
+pkgdesc="Pulse-Eight's libcec for the Pulse-Eight USB-CEC adapter"
+arch=('i686' 'x86_64')
+url="https://github.com/Pulse-Eight/libcec"
+license=('GPL')
+makedepends=('git')
+depends=('udev>=151')
+provides=('libcec')
+conflicts=('libcec')
+options=('!libtool')
+
+_gitroot="https://github.com/Pulse-Eight/libcec.git"
+_gitname="libcec"
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build"
+
+ autoreconf -vif
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$_gitname-build"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: