summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD31
2 files changed, 14 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b5ca4657f41..b29a95fe728b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libclc-minimal-git
pkgdesc = companion package to llvm-minimal-git, Library requirements of the OpenCL C programming language
- pkgver = 19.0.0_r496033.5a0942cd7423
+ pkgver = 19.0.0_r496188.172f6ddfa766
pkgrel = 1
url = https://libclc.llvm.org/
arch = any
@@ -11,19 +11,12 @@ pkgbase = libclc-minimal-git
makedepends = git
makedepends = python
makedepends = spirv-llvm-translator-minimal-git
+ makedepends = ninja
provides = libclc
conflicts = libclc
options = !lto
options = !debug
source = git+https://github.com/llvm/llvm-project.git
- source = libclc_Refactor_build_system_to_allow_in-tree_builds_#87622.patch::https://github.com/llvm/llvm-project/commit/72f9881c3ffcf4be6361c3e4312d91c9c8d94a98.patch
- source = libclc_Give_built_bytecode_objects_a_.bc_extension_NFC.patch::https://github.com/llvm/llvm-project/commit/a0f8191af3945482f0f7a7c8f030e8c519a795b7.patch
- source = libclc_Fix_dependencies_between_targets.patch::https://github.com/llvm/llvm-project/commit/3d118f92081ea0c7048749dc5d08c8e8217be4eb.patch
- source = libclc_Improve_clarity_of_CMake_foreach_NFC.patch::https://github.com/llvm/llvm-project/commit/9d111286322ec99b32467eef3aeec6b588c49f18.patch
sha256sums = SKIP
- sha256sums = 142f7d406efc83e07483490763b604520ac2c9542744b05e1af0e9ae0a9d212b
- sha256sums = ce8cb4bcf3033100bf80d2bbe9378584079bd539db9ccad943c1e029d9c9ac65
- sha256sums = 48378f2b474e518109d8f8b20fee7c079c5dff0d01b8658916d11ce650853257
- sha256sums = 9d70fadb2f9219d5d430240ee1485440666ce94110451647b7f5b5d5332592ca
pkgname = libclc-minimal-git
diff --git a/PKGBUILD b/PKGBUILD
index c3b6f44b6ca8..81f402f8fa41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Solomon Choina <shlomochoina@gmail.com>
pkgname=libclc-minimal-git
-pkgver=19.0.0_r496033.5a0942cd7423
+pkgver=19.0.0_r496188.172f6ddfa766
pkgrel=1
pkgdesc="companion package to llvm-minimal-git, Library requirements of the OpenCL C programming language"
arch=('any')
@@ -11,21 +11,18 @@ url="https://libclc.llvm.org/"
license=('custom:Apache 2.0 with LLVM Exception')
provides=(libclc)
conflicts=(libclc)
-makedepends=(llvm-minimal-git clang-minimal-git cmake git python spirv-llvm-translator-minimal-git)
-# makedepends=(llvm-minimal-git clang-minimal-git cmake git python spirv-llvm-translator-minimal-git 'llvm-libs<19')
+makedepends=(llvm-minimal-git clang-minimal-git cmake git python spirv-llvm-translator-minimal-git ninja)
source=("git+https://github.com/llvm/llvm-project.git"
-"libclc_Refactor_build_system_to_allow_in-tree_builds_#87622.patch::https://github.com/llvm/llvm-project/commit/72f9881c3ffcf4be6361c3e4312d91c9c8d94a98.patch"
-"libclc_Give_built_bytecode_objects_a_.bc_extension_NFC.patch::https://github.com/llvm/llvm-project/commit/a0f8191af3945482f0f7a7c8f030e8c519a795b7.patch"
-"libclc_Fix_dependencies_between_targets.patch::https://github.com/llvm/llvm-project/commit/3d118f92081ea0c7048749dc5d08c8e8217be4eb.patch"
-"libclc_Improve_clarity_of_CMake_foreach_NFC.patch::https://github.com/llvm/llvm-project/commit/9d111286322ec99b32467eef3aeec6b588c49f18.patch"
)
sha256sums=('SKIP'
- '142f7d406efc83e07483490763b604520ac2c9542744b05e1af0e9ae0a9d212b'
- 'ce8cb4bcf3033100bf80d2bbe9378584079bd539db9ccad943c1e029d9c9ac65'
- '48378f2b474e518109d8f8b20fee7c079c5dff0d01b8658916d11ce650853257'
- '9d70fadb2f9219d5d430240ee1485440666ce94110451647b7f5b5d5332592ca')
+)
options=(!lto !debug)
+# ninja grabs all available cores and leaves almost nothing for other processes.
+# this package uses the environment variable NINJAFLAGS to allow the user to change this behaviour
+# The responsibility to validate the value of NINJAFLAGS lies with the user.
+# If unsure, use NINJAFLAGS=""
+
prepare() {
cd llvm-project
local _commit_hash=$(echo $(pacman -Q llvm-minimal-git) | cut -d' ' -f2 | cut -d'-' -f1 | cut -d'.' -f4)
@@ -39,12 +36,6 @@ prepare() {
# the 3rd removes (revision count) r461863 so only (the commit hash) 8064caf83fb1 remains
git reset --hard $_commit_hash
-
- # revert changes to libclc that causes build failure, see https://github.com/llvm/llvm-project/issues/88626
- patch --reverse --strip=1 --input=$srcdir/libclc_Improve_clarity_of_CMake_foreach_NFC.patch
- patch --reverse --strip=1 --input=$srcdir/libclc_Fix_dependencies_between_targets.patch
- patch --reverse --strip=1 --input=$srcdir/libclc_Give_built_bytecode_objects_a_.bc_extension_NFC.patch
- patch --reverse --strip=1 --input=$srcdir/libclc_Refactor_build_system_to_allow_in-tree_builds_#87622.patch
}
pkgver() {
@@ -65,15 +56,17 @@ build() {
cmake \
-B _build \
-S "$srcdir"/llvm-project/libclc \
+ -G Ninja \
-D CMAKE_BUILD_TYPE=Release \
-D CMAKE_INSTALL_PREFIX=/usr \
-Wno-dev
- make -C _build
+ ninja $NINJAFLAGS -C _build
+
}
package() {
- make -C _build DESTDIR="$pkgdir" install
+ DESTDIR="${pkgdir}" ninja $NINJAFLAGS -C _build install
install -Dm644 "$srcdir"/llvm-project/libclc/LICENSE.TXT "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.TXT
}