summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore11
-rw-r--r--PKGBUILD25
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab71ec853508
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libdiscid-sharp
+ pkgdesc = Mono bindings for libdiscid
+ pkgver = 0.2.0
+ pkgrel = 2
+ url = https://github.com/phw/dotnet-discid/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ makedepends = mono
+ depends = mono
+ depends = libdiscid
+ provides = libdiscid-sharp
+ source = http://users.musicbrainz.org/~outsidecontext/dotnet-discid/dotnet-discid-0.2.0.tar.gz
+ md5sums = 5d18b4bff6ff59c27e3042fdaedabda3
+
+pkgname = libdiscid-sharp
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..20625a9e1d7c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,11 @@
+src/*
+pkg/*
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.zip
+*.gem
+*.air
+*.part
+*~
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56d8cab4bcfc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Philipp Wolfer <ph.wolfer@gmail.com>
+
+pkgname=libdiscid-sharp
+pkgver=0.2.0
+pkgrel=2
+pkgdesc="Mono bindings for libdiscid"
+arch=('i686' 'x86_64')
+url="https://github.com/phw/dotnet-discid/"
+license=('LGPL')
+provides=('libdiscid-sharp')
+depends=('mono' 'libdiscid')
+makedepends=('git' 'mono')
+source=("http://users.musicbrainz.org/~outsidecontext/dotnet-discid/dotnet-discid-0.2.0.tar.gz")
+md5sums=('5d18b4bff6ff59c27e3042fdaedabda3')
+
+build() {
+ cd dotnet-discid-${pkgver}
+ ./configure --prefix=/usr --config=RELEASE
+ make
+}
+
+package() {
+ cd dotnet-discid-${pkgver}
+ make DESTDIR=${pkgdir} install
+} \ No newline at end of file