summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1edcd5e2815
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libfnr-git
+ pkgdesc = Format-preserving encryption (FPE), small cipher (< 128 bits), for anonymization.
+ pkgver = r105.400cf06
+ pkgrel = 1
+ url = http://cisco.github.io/libfnr/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ depends = openssl
+ provides = libfnr=r105.400cf06
+ conflicts = libfnr
+ options = !libtool
+ source = libfnr-git::git+https://github.com/cisco/libfnr.git
+ md5sums = SKIP
+
+pkgname = libfnr-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..328c53c31361
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Jiri Prochazka <ojirio@gmail.com>
+
+pkgname=libfnr-git
+pkgdesc="Format-preserving encryption (FPE), small cipher (< 128 bits), for anonymization."
+pkgver=r105.400cf06
+pkgrel=1
+arch=(i686 x86_64)
+url=http://cisco.github.io/libfnr/
+license=(LGPL)
+depends=(openssl)
+makedepends=(git)
+provides=(${pkgname%-*}=$pkgver)
+conflicts=(${pkgname%-*})
+options=(!libtool)
+source=($pkgname::git+https://github.com/cisco/${pkgname%-*}.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$pkgname"
+ . bootstrap.sh
+ autoreconf -fi
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir" install
+ rm -rf "$pkgdir"/usr/bin # exclude test binaries
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+}
+