summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD42
2 files changed, 25 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 766c0b5766c3..eeb0cc00a792 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
-# Generated by mksrcinfo v8
-# Fri Dec 1 19:29:23 UTC 2017
pkgbase = libframe
- pkgdesc = The LIGO Scientific Consortium Algorithm Library Suite. libframe
+ pkgdesc = The LIGO Scientific Consortium Algorithm Library Suite
pkgver = 8.30
- pkgrel = 8
+ pkgrel = 9
url = https://wiki.ligo.org/DASWG/LALSuiteInstall
- arch = any
+ arch = x86_64
groups = lalsuite
- license = unknown
- options = !emptydirs
- source = http://software.ligo.org/lscsoft/source/libframe-8.30.tar.gz
+ license = custom
+ depends = glibc
+ provides = libFrame.so
+ source = libframe-8.30.tar.gz::https://software.ligo.org/lscsoft/source/libframe-8.30.tar.gz
sha256sums = 374743ccce835427a0900590a515c112661760e12ec596159d3f86073dd099da
pkgname = libframe
-
diff --git a/PKGBUILD b/PKGBUILD
index 599a0ee74739..142d76a622cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,27 @@
-# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
+
pkgname=libframe
-_pkgname=${pkgname}
pkgver=8.30
-pkgrel=8
-pkgdesc="The LIGO Scientific Consortium Algorithm Library Suite. ${_pkgname}"
-arch=(any)
+pkgrel=9
+pkgdesc="The LIGO Scientific Consortium Algorithm Library Suite"
+arch=('x86_64')
url="https://wiki.ligo.org/DASWG/LALSuiteInstall"
-license=('unknown')
+license=('custom')
groups=('lalsuite')
-depends=()
-makedepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=(!emptydirs)
-install=
-source=("http://software.ligo.org/lscsoft/source/${_pkgname}-${pkgver}.tar.gz")
+depends=('glibc')
+provides=("libFrame.so")
+source=("$pkgname-$pkgver.tar.gz::https://software.ligo.org/lscsoft/source/$pkgname-$pkgver.tar.gz")
sha256sums=('374743ccce835427a0900590a515c112661760e12ec596159d3f86073dd099da')
+
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- ./configure --prefix=${pkgdir}/usr CFLAGS='-O3 -Wno-error'
- make -j
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
}
-#check() {
-# cd "${srcdir}/${_pkgname}-${pkgver}"
-# make -j check
-#}
+
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- make install
+ cd "$pkgname-$pkgver"
+ DESTDIR="$pkgdir" make install
+ install -Dvm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
}