summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..529099503d89
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = libggiwmh
+ pkgdesc = A libggi extension whereby wmh stands for 'Window Manager Hints'
+ pkgver = 0.3.2
+ pkgrel = 1
+ url = http://ibiblio.org/ggicore/packages/libggiwmh.html
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = libggi
+ source = http://downloads.sourceforge.net/project/ggi/misc/libggiwmh-0.3.2/libggiwmh-0.3.2.src.tar.gz
+ md5sums = 833ca6eb19b83c3c35d07ea3cf44e12b
+
+pkgname = libggiwmh
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05ed816b621a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
+pkgname=libggiwmh
+pkgver=0.3.2
+pkgrel=1
+pkgdesc="A libggi extension whereby wmh stands for 'Window Manager Hints'"
+arch=('i686' 'x86_64')
+url="http://ibiblio.org/ggicore/packages/${pkgname}.html"
+license=('custom')
+depends=('libggi')
+source=("http://downloads.sourceforge.net/project/ggi/misc/${pkgname}-${pkgver}/${pkgname}-${pkgver}.src.tar.gz")
+md5sums=('833ca6eb19b83c3c35d07ea3cf44e12b')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/usr/share/man \
+ --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make install DESTDIR=${pkgdir}
+ install -Dm644 "COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}