summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
-rw-r--r--libhelium.patch23
3 files changed, 43 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ebd87ff3f29..1afc63f7906d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libhelium
pkgdesc = The application framework for tauOS apps.
- pkgver = 1.8.9
- pkgrel = 2
+ pkgver = 1.8.10
+ pkgrel = 1
url = https://github.com/tau-OS/libhelium
arch = x86_64
arch = aarch64
@@ -15,7 +15,9 @@ pkgbase = libhelium
depends = gtk4
depends = glib2
depends = libgee
- source = libhelium-1.8.9.tar.gz::https://github.com/tau-OS/libhelium/archive/refs/tags/1.8.9.tar.gz
- sha256sums = 8ec5fa64f64b77524993b959d6309798f35fa8326bbad5ec28a59f15b562e532
+ source = libhelium-1.8.10.tar.gz::https://github.com/tau-OS/libhelium/archive/refs/tags/1.8.10.tar.gz
+ source = libhelium.patch
+ sha256sums = f4963b7196e6456d6ba733f24ec7a746d1372ac84bd7677a4d960606b4e3c5c3
+ sha256sums = 332dea0fe8126f5e347e17f11dbaad5b565c7f99cf20424e7711aa29011ec858
pkgname = libhelium
diff --git a/PKGBUILD b/PKGBUILD
index 2466f0739b61..4cb247c32247 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Alyxia Sother <nylkvn@evfrhc.arg(rot13)>
pkgname=libhelium
-pkgver=1.8.9
-pkgrel=2
+pkgver=1.8.10
+pkgrel=1
pkgdesc="The application framework for tauOS apps."
arch=('x86_64' 'aarch64')
depends=('gtk4' 'glib2' 'libgee')
@@ -17,13 +17,18 @@ makedepends=(
url="https://github.com/tau-OS/libhelium"
license=('LGPL3')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/tau-OS/libhelium/archive/refs/tags/$pkgver.tar.gz")
-sha256sums=('8ec5fa64f64b77524993b959d6309798f35fa8326bbad5ec28a59f15b562e532')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/tau-OS/libhelium/archive/refs/tags/$pkgver.tar.gz"
+ "$pkgname.patch")
+sha256sums=('f4963b7196e6456d6ba733f24ec7a746d1372ac84bd7677a4d960606b4e3c5c3'
+ '332dea0fe8126f5e347e17f11dbaad5b565c7f99cf20424e7711aa29011ec858')
prepare() {
cd "$srcdir/libhelium-$pkgver"
meson subprojects download
+
+ # Removes the automatic schema compilation, we're doing this ourselves
+ patch --strip=1 --input="$srcdir/$pkgname.patch"
}
build() {
@@ -37,4 +42,9 @@ package() {
cd "$srcdir/libhelium-$pkgver"
meson install -C builddir --destdir "$pkgdir"
+
+ # Manually add the schema into the right data dir.
+ # We don't have to call glib-compile-schemas as glib2 contains a hook:
+ # <https://gitlab.archlinux.org/archlinux/packaging/packages/glib2/-/blob/main/glib-compile-schemas.hook?ref_type=heads>
+ install -Dm644 data/com.fyralabs.desktop.appearance.gschema.xml "$pkgdir/usr/share/glib-2.0/schemas/com.fyralabs.desktop.appearance.gschema.xml"
}
diff --git a/libhelium.patch b/libhelium.patch
new file mode 100644
index 000000000000..20d1e64151c1
--- /dev/null
+++ b/libhelium.patch
@@ -0,0 +1,23 @@
+diff --color '--color=auto' --unified --unified --recursive --text libhelium-1.8.10/meson.build altered/meson.build
+--- libhelium-1.8.10/meson.build 2024-02-02 19:28:31.000000000 +0100
++++ altered/meson.build 2024-02-05 19:49:36.677996127 +0100
+@@ -107,19 +107,3 @@
+ if get_option('gidoc') or get_option('valadoc')
+ subdir('doc')
+ endif
+-
+-# GSettings schemas, merged from tau-gsettings-schemas since
+-# it's now standard for all Helium-based apps.
+-
+-settings_schemas = [ 'data/com.fyralabs.desktop.appearance.gschema.xml' ]
+-
+-gnome.compile_schemas(depend_files: files(settings_schemas))
+-
+-schemas_dir = get_option('prefix') / get_option('datadir') / 'glib-2.0' / 'schemas'
+-
+-install_data(settings_schemas, install_dir: schemas_dir)
+-
+-meson.add_install_script('glib-compile-schemas', schemas_dir)
+-
+-
+-# end schema stuff