summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a23289e7be1b..22d9369bbe9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libidn-git
pkgdesc = An implementation of the Stringprep, Punycode and IDNA 2003 specifications
- pkgver = 1.33.r47.g13f07cbf
- pkgrel = 2
+ pkgver = 1.41.r30.g674e0fe1
+ pkgrel = 1
url = https://www.gnu.org/software/libidn/
arch = i686
arch = x86_64
@@ -14,11 +14,10 @@ pkgbase = libidn-git
makedepends = fig2dev
makedepends = ghostscript
depends = glibc
- provides = libidn
+ provides = libidn=1.41.r30.g674e0fe1
conflicts = libidn
options = staticlibs
source = git+https://git.savannah.gnu.org/git/libidn.git
sha256sums = SKIP
pkgname = libidn-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 7c94e041a1b8..f53b04b39309 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=libidn-git
-pkgver=1.33.r47.g13f07cbf
-pkgrel=2
+pkgver=1.41.r30.g674e0fe1
+pkgrel=1
pkgdesc="An implementation of the Stringprep, Punycode and IDNA 2003 specifications"
arch=('i686' 'x86_64')
url="https://www.gnu.org/software/libidn/"
license=('GPL' 'LGPL')
depends=('glibc')
makedepends=('git' 'gengetopt' 'gperf' 'gtk-doc' 'fig2dev' 'ghostscript')
-provides=('libidn')
+provides=("libidn=$pkgver")
conflicts=('libidn')
options=('staticlibs')
source=("git+https://git.savannah.gnu.org/git/libidn.git")
@@ -19,14 +19,18 @@ sha256sums=('SKIP')
pkgver() {
cd "libidn"
- git describe --long --tags | sed 's/^libidn.//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ _tag=$(git tag -l --sort -v:refname | grep -E '^v?[0-9\.]+$' | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//'
}
build() {
cd "libidn"
make bootstrap
- ./configure --prefix="/usr"
+ ./configure \
+ --prefix="/usr"
make
}