summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD56
2 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..624d5d53a5ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = libint-cp2k
+ pkgdesc = A high-performance library for computing Gaussian integrals in quantum mechanics (cp2k edition)
+ pkgver = 2.7.0.beta.5
+ pkgrel = 1
+ url = https://github.com/cp2k/libint-cp2k
+ arch = x86_64
+ license = GPL
+ makedepends = python
+ makedepends = gcc-fortran
+ makedepends = cmake
+ makedepends = automake
+ makedepends = autoconf
+ makedepends = eigen
+ depends = boost
+ provides = libint2
+ conflicts = libint2
+ options = staticlibs
+ source = https://github.com/cp2k/libint-cp2k/releases/download/v2.7.0-beta.5/libint-v2.7.0-beta.5-cp2k-lmax-7.tgz
+ sha256sums = 523e93da19652ae78ebaaa7c646dd2cd2f93809ca0c5a1f325e80f1d264af8e1
+
+pkgname = libint-cp2k
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d321b9daab1f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Kars Wang <jaklsy [at] gmail [dot] com>
+
+_pkgname=libint
+_lmax_ver=7
+pkgname=libint-cp2k
+pkgver=2.7.0.beta.5
+_pkgver="$(sed 's/\.beta/-beta/' <<< "${pkgver}")"
+__pkgver="v${_pkgver}-cp2k-lmax-${_lmax_ver}"
+pkgrel=1
+pkgdesc='A high-performance library for computing Gaussian integrals in quantum mechanics (cp2k edition)'
+url='https://github.com/cp2k/libint-cp2k'
+license=('GPL')
+arch=('x86_64')
+depends=('boost')
+makedepends=('python' 'gcc-fortran' 'cmake' 'automake' 'autoconf' 'eigen')
+provides=('libint2')
+conflicts=('libint2')
+source=("https://github.com/cp2k/libint-cp2k/releases/download/v${_pkgver}/${_pkgname}-${__pkgver}.tgz")
+sha256sums=('523e93da19652ae78ebaaa7c646dd2cd2f93809ca0c5a1f325e80f1d264af8e1')
+options=(staticlibs)
+
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${__pkgver}"
+
+ # Setting build environment
+ export CC=gcc
+ export CXX=g++
+ export FC=gfortran
+ export CXXGENFLAGS="$CXXFLAGS"
+
+ mkdir -p build
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}-${__pkgver}/build"
+
+ cmake .. -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_CXX_COMPILER="$CXX" \
+ -DLIBINT2_INSTALL_LIBDIR="/usr/lib" \
+ -DENABLE_FORTRAN=ON \
+ -DCXXFLAGS="$CXXFLAGS -g1"
+
+ cmake --build .
+}
+
+# check() {
+# libint_build_dir="${srcdir}/build_libint"
+# cd "$libint_build_dir/${_pkgname}-${__pkgver}"
+# cmake --build . --target check
+# }
+
+package() {
+ cd "${srcdir}/${_pkgname}-${__pkgver}/build"
+ cmake --build . --target install -- DESTDIR="${pkgdir}"
+}