summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore9
-rw-r--r--LICENSE9
-rw-r--r--PKGBUILD38
4 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..78c7382ea365
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libisocodes
+ pkgdesc = Easily access XML data of the iso-codes package
+ pkgver = 1.2.5
+ pkgrel = 1
+ url = https://github.com/toddy15/libisocodes
+ arch = x86_64
+ license = GPL-3.0-or-later
+ makedepends = gobject-introspection
+ makedepends = vala
+ depends = glib2
+ depends = libgee
+ depends = libxml2
+ provides = libisocodes.so=1
+ source = libisocodes-1.2.5.tar.gz::https://github.com/toddy15/libisocodes/archive/refs/tags/v1.2.5.tar.gz
+ sha256sums = cbf299de4a6ebf9e0f0cab437c1d2844c603fa479a56dbb83cee3b6684f5dc53
+
+pkgname = libisocodes
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fbf13ff84003
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+# Ignore everything
+/*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!.nvchecker.toml
+!LICENSE
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..733e88560b9d
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,9 @@
+Binary files, as well as any files describing changes ("patches") to the software that is being built are excluded from this license. They are provided under the license terms of the software they describe changes for.
+
+Any files containing a license notice are excluded from this license. They are provided under the license terms defined in their respective notices.
+
+Copyright 2024 Arch Linux Contributors
+
+Permission to use, copy, modify, and/or distribute this software for any purpose with or without fee is hereby granted.
+
+THE SOFTWARE IS PROVIDED “AS IS” AND THE AUTHOR DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8fe8c5a81f2b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
+pkgname=libisocodes
+pkgver=1.2.5
+pkgrel=1
+epoch=
+pkgdesc="Easily access XML data of the iso-codes package"
+arch=('x86_64')
+url="https://github.com/toddy15/libisocodes"
+license=('GPL-3.0-or-later')
+depends=(
+ 'glib2'
+ 'libgee'
+ 'libxml2'
+)
+makedepends=(
+ 'gobject-introspection'
+ 'vala'
+)
+#checkdepends=('iso-codes')
+provides=('libisocodes.so=1')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('cbf299de4a6ebf9e0f0cab437c1d2844c603fa479a56dbb83cee3b6684f5dc53')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+#check() {
+# cd "$pkgname-$pkgver"
+# make -k check ## TODO
+#}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}