summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD47
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d36aca7b156
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libivykis-git
+ pkgdesc = Library for asynchronous I/O readiness notification
+ pkgver = v0.42.3.trunk.r1.g8f8eb78
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/buytenh/ivykis
+ arch = i686
+ arch = x86_64
+ license = LGPL-2.1
+ provides = libivykis
+ conflicts = libivykis
+ source = git+https://github.com/buytenh/ivykis.git
+ md5sums = SKIP
+
+pkgname = libivykis-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a3dcd2906b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Bruno ReniƩ <brutasse@gmail.com>
+pkgname=libivykis-git
+epoch=1
+pkgver=v0.42.3.trunk.r1.g8f8eb78
+pkgrel=1
+pkgdesc="Library for asynchronous I/O readiness notification"
+url="https://github.com/buytenh/ivykis"
+arch=('i686' 'x86_64')
+license=('LGPL-2.1')
+depends=()
+makedepends=()
+provides=('libivykis')
+conflicts=('libivykis')
+source=("git+https://github.com/buytenh/ivykis.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ivykis
+
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd ivykis
+
+ pushd test.mt
+ aclocal
+ autoheader
+ libtoolize --ltdl --copy --force
+ automake --add-missing --copy --foreign
+ autoconf
+ popd
+
+ aclocal
+ autoheader
+ libtoolize --ltdl --copy --force
+ automake --add-missing --copy --foreign
+ autoconf
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ivykis
+
+ make DESTDIR="$pkgdir" install
+}