summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--CHANGELOG7
-rw-r--r--PKGBUILD16
3 files changed, 21 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1253d400f046..a1762b83cea7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = liblsdj-git
pkgdesc = Library for working with the LSDj save file format
pkgver = 2.1.0
- pkgrel = 0
+ pkgrel = 1
url = https://github.com/stijnfrishert/libLSDJ
+ changelog = CHANGELOG
arch = any
license = MIT
makedepends = cmake
@@ -12,7 +13,7 @@ pkgbase = liblsdj-git
provides = lsdj-mono
provides = lsdj-wavetable-import
source = liblsdj::git+https://github.com/stijnfrishert/libLSDJ.git
- source = Catch2::git+https://github.com/catchorg/Catch2.git#tag=v2.13.5
+ source = Catch2::git+https://github.com/catchorg/Catch2.git
sha256sums = SKIP
sha256sums = SKIP
diff --git a/CHANGELOG b/CHANGELOG
new file mode 100644
index 000000000000..cf968a73a7b2
--- /dev/null
+++ b/CHANGELOG
@@ -0,0 +1,7 @@
+2.1.0-0
+ initial commit to the AUR. For older changes, consult the github repository
+
+2.1.0-1
+ fixed compilation errors in upstream repository
+ removed the workaround in the PKGBUILD
+ added this changelog \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index dcc5b56e7b44..c4b2f0885327 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,8 @@
_pkgname=liblsdj
pkgname=${_pkgname}-git
pkgver=2.1.0
-pkgrel=0
+pkgrel=1
+changelog=CHANGELOG
pkgdesc='Library for working with the LSDj save file format'
arch=('any')
url='https://github.com/stijnfrishert/libLSDJ'
@@ -11,18 +12,23 @@ license=('MIT')
provides=('lsdsng-export' 'lsdsng-import' 'lsdj-mono' 'lsdj-wavetable-import')
depends=()
makedepends=('cmake' 'git')
-#TODO: set back to original author's repo once they fix the submodule version
source=("$_pkgname::git+https://github.com/stijnfrishert/libLSDJ.git"
- "Catch2::git+https://github.com/catchorg/Catch2.git#tag=v2.13.5")
+ "Catch2::git+https://github.com/catchorg/Catch2.git")
sha256sums=('SKIP' 'SKIP')
prepare() {
- rm $_pkgname/dependency/Catch2 -drf
- mv Catch2 $_pkgname/dependency
cd $_pkgname
+ echo "init"
+ git submodule init dependency/Catch2
+ echo "url"
+ git config submodule.Catch2.url "$srcdir/Catch2"
+ echo "update"
+ git submodule update --init
+ echo "rest"
mkdir build -p
cd build
cmake -DCMAKE_BUILD_TYPE=Release ..
+ echo "victory!"
}
build() {