summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD59
-rw-r--r--components.config1
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f7dbbfca105d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = libmtk-git
+ pkgdesc = A library to allow shared object modules to be loaded dynamically into a running PCB plug-in
+ pkgver = 0.1.0.r0.g365e6ee
+ pkgrel = 1
+ url = https://gitlab.com/soft.at.home/pcb/libmtk.git
+ arch = any
+ license = MIT
+ makedepends = sah_components_config
+ makedepends = m4
+ makedepends = gcc
+ makedepends = make
+ depends = libsahtrace
+ depends = libpcb
+ provides = libmtk
+ provides = libmtk-git
+ conflicts = libmtk
+ conflicts = libmtk-git
+ source = libmtk-git::git+https://gitlab.com/soft.at.home/pcb/libmtk.git#branch=master
+ source = components.config
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = libmtk-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3cafac4664a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: fenrig <fenrig.linux at outlook.com>
+pkgname=libmtk-git
+pkgver=0.1.0.r0.g365e6ee
+pkgrel=1
+pkgdesc="A library to allow shared object modules to be loaded dynamically into a running PCB plug-in"
+arch=('any')
+url="https://gitlab.com/soft.at.home/pcb/libmtk.git"
+license=('MIT')
+
+depends=(
+ 'libsahtrace'
+ 'libpcb'
+)
+makedepends=(
+ 'sah_components_config'
+ 'm4'
+ 'gcc'
+ 'make'
+)
+provides=(
+ 'libmtk'
+ 'libmtk-git'
+)
+conflicts=(
+ 'libmtk'
+ 'libmtk-git'
+)
+
+gitbranch="master"
+
+source=("${pkgname}::git+https://gitlab.com/soft.at.home/pcb/libmtk.git#branch=${gitbranch}" "components.config")
+md5sums=('SKIP' 'SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ sah_components_config
+ ! mkdir include
+ cp -f components.h include/components.h
+}
+
+build() {
+ # STAGINGDIR
+ export STAGINGDIR=$(pwd)
+ cd "${pkgname}"
+ make -C pkgconfig clean
+ make -C src clean
+ make
+}
+
+package() {
+ cd "${pkgname}"
+ make D="${pkgdir}/" install
+ mv ${pkgdir}/lib/* ${pkgdir}/usr/lib/
+ rm -Rf ${pkgdir}/lib/
+}
diff --git a/components.config b/components.config
new file mode 100644
index 000000000000..e11b2742359a
--- /dev/null
+++ b/components.config
@@ -0,0 +1 @@
+CONFIG_SAH_LIB_MTK=y