summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0934c671e35d..55689cdb6fdb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = libonvif
- pkgver = 3.1.0
+ pkgver = 3.1.1
pkgrel = 1
url = https://github.com/sr99622/libonvif
arch = i686
@@ -13,8 +13,8 @@ pkgbase = libonvif
makedepends = python-installer
makedepends = python-setuptools
makedepends = python-wheel
- source = git+https://github.com/sr99622/libonvif.git#commit=5c8433978a1bc15a5b662b451759af4f5d7e27be
- sha256sums = 3db685e429d00f733307b8c056a63817b864162d6b6d404ec83966138273ed8a
+ source = git+https://github.com/sr99622/libonvif.git#commit=b21f043dea0e4401fd59bed069d6fe306c37ab22
+ sha256sums = 1b7ba19e99c446a6fc752faba42ce4350eeec2436f9b6ff7b78eae6648196884
pkgname = libonvif
pkgdesc = A client side implementation of the ONVIF specification - library
diff --git a/PKGBUILD b/PKGBUILD
index 1be5718a6580..b424b5cfef8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgbase=libonvif
pkgname=('libonvif' 'python-libonvif')
-pkgver=3.1.0
+pkgver=3.1.1
pkgrel=1
url='https://github.com/sr99622/libonvif'
license=('LGPL-2.1-or-later')
@@ -17,9 +17,9 @@ makedepends=('cmake'
'python-installer'
'python-setuptools'
'python-wheel')
-# _prjrel=2.0.1
-source=("git+${url}.git#commit=5c8433978a1bc15a5b662b451759af4f5d7e27be")
-sha256sums=('3db685e429d00f733307b8c056a63817b864162d6b6d404ec83966138273ed8a')
+# _prjrel=2.0.9
+source=("git+${url}.git#commit=b21f043dea0e4401fd59bed069d6fe306c37ab22")
+sha256sums=('1b7ba19e99c446a6fc752faba42ce4350eeec2436f9b6ff7b78eae6648196884')
prepare() {
cd ${srcdir}/${pkgbase}/libonvif
@@ -36,7 +36,8 @@ build() {
cmake -B build-so \
-D CMAKE_BUILD_TYPE=Release \
-D CMAKE_INSTALL_PREFIX=/usr \
- -D WITHOUT_PYTHON=true
+ -D WITHOUT_PYTHON=true \
+ -W no-dev
cmake --build build-so
python -m build --wheel --no-isolation
}