summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--0001-Revert-Drop-install-target-and-documentation.patch30
-rw-r--r--PKGBUILD4
3 files changed, 22 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0638e97ded12..bd2f415adc75 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libopencm3-git
pkgdesc = Open Source firmware library for various ARM Cortex microcontrollers
- pkgver = r2314.f5d2d8f1
+ pkgver = r2759.3b89fc59
pkgrel = 1
url = http://www.libopencm3.org/
arch = any
@@ -15,7 +15,6 @@ pkgbase = libopencm3-git
source = git://github.com/libopencm3/libopencm3.git
source = 0001-Revert-Drop-install-target-and-documentation.patch
sha256sums = SKIP
- sha256sums = 457dc2d2810e2b7ac857952021f5092a0de923069645f50f9c95a09c86b52158
+ sha256sums = fed65c22533a8fb5a40a5eb0abf65051f6e38d87d1a3d2231094701e222857d5
pkgname = libopencm3-git
-
diff --git a/0001-Revert-Drop-install-target-and-documentation.patch b/0001-Revert-Drop-install-target-and-documentation.patch
index 6d4f01e3a586..999f70860b69 100644
--- a/0001-Revert-Drop-install-target-and-documentation.patch
+++ b/0001-Revert-Drop-install-target-and-documentation.patch
@@ -1,8 +1,16 @@
+commit 33f456aad9313bfc42e5ae7ef47e7976b0572a71
+Author: Anatol Pomozov <anatol.pomozov@gmail.com>
+Date: Sun Jan 10 18:58:44 2016 -0800
+
+ Revert "Drop "install" target and documentation."
+
+ This reverts commit 7c1cd2e5cd3f3d1193ee375b46cfd8afaccb89f7.
+
diff --git a/Makefile b/Makefile
-index 6929769d..ca06efd7 100644
+index 20f878fa..97f63933 100644
--- a/Makefile
+++ b/Makefile
-@@ -23,6 +23,13 @@ PREFIX ?= arm-none-eabi
+@@ -22,6 +22,13 @@ PREFIX ?= arm-none-eabi-
STYLECHECK := scripts/checkpatch.pl
STYLECHECKFLAGS := --no-tree -f --terse --mailback
@@ -13,12 +21,12 @@ index 6929769d..ca06efd7 100644
+SHAREDIR := $(DESTDIR)/$(PREFIX)/share/libopencm3/scripts
+INSTALL := install
+
- space:=
- space+=
- SRCLIBDIR:= $(subst $(space),\$(space),$(realpath lib))
-@@ -70,6 +77,22 @@ $(LIB_DIRS): $(IRQ_DEFN_FILES:=.genhdr)
- lib: $(LIB_DIRS)
- $(Q)true
+ TARGETS ?= stm32/f0 stm32/f1 stm32/f2 stm32/f3 stm32/f4 stm32/f7 \
+ stm32/l0 stm32/l1 stm32/l4 \
+ stm32/g0 stm32/g4 \
+@@ -80,6 +87,20 @@ lib: $(LIB_DIRS)
+ done;
+ $(Q)[ -f .stamp_failure_tld ] && cat .stamp_failure_tld && exit 1 || true;
+install: lib
+ @printf " INSTALL headers\n"
@@ -32,14 +40,12 @@ index 6929769d..ca06efd7 100644
+ $(Q)$(INSTALL) -m 0644 lib/*.a $(LIBDIR)
+ @printf " INSTALL ldscripts\n"
+ $(Q)$(INSTALL) -m 0644 lib/*.ld $(LIBDIR)
-+ $(Q)$(INSTALL) -m 0644 lib/*/*.ld $(LIBDIR)
-+ $(Q)$(INSTALL) -m 0644 lib/*/*/*.ld $(LIBDIR)
+
+
html doc:
- $(Q)$(MAKE) -C doc html
+ $(Q)$(MAKE) -C doc html TARGETS="$(TARGETS)"
-@@ -114,4 +137,4 @@ genlinktests.clean:
+@@ -125,4 +146,4 @@ genlinktests.clean:
fi;
diff --git a/PKGBUILD b/PKGBUILD
index 08d9023a4f85..843ce7f297b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Martin Schmölzer <mschmoelzer@gmail.com>
pkgname=libopencm3-git
-pkgver=r2314.f5d2d8f1
+pkgver=r2759.3b89fc59
pkgrel=1
pkgdesc='Open Source firmware library for various ARM Cortex microcontrollers'
arch=(any)
@@ -12,7 +12,7 @@ options=(!strip staticlibs !buildflags)
source=(git://github.com/libopencm3/libopencm3.git
0001-Revert-Drop-install-target-and-documentation.patch)
sha256sums=('SKIP'
- '457dc2d2810e2b7ac857952021f5092a0de923069645f50f9c95a09c86b52158')
+ 'fed65c22533a8fb5a40a5eb0abf65051f6e38d87d1a3d2231094701e222857d5')
pkgver() {
cd libopencm3