summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD30
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a4b50bdad878
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = libpafe-ruby
+ pkgdesc = A library using the libpafe on ruby
+ pkgver = 0.0.8
+ pkgrel = 1
+ url = http://homepage3.nifty.com/slokar/pasori/libpafe-ruby.html
+ arch = any
+ license = GPL2
+ depends = libpafe
+ depends = ruby
+ source = http://homepage3.nifty.com/slokar/pasori/libpafe-ruby-0.0.8.tar.gz
+ sha256sums = 496b5f6299c14b6b11e4bd8fb1f2bd093ed75a6fee23635a1eb257b762e216cc
+
+pkgname = libpafe-ruby
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..092a57bab087
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+libpafe-ruby-*.tar.gz
+libpafe-ruby-*.tar.xz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58c58d9f4eb9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Masanori Ohgita <mp at ohgita dot info>
+pkgname=libpafe-ruby
+pkgver=0.0.8
+pkgrel=1
+pkgdesc='A library using the libpafe on ruby'
+arch=('any')
+url='http://homepage3.nifty.com/slokar/pasori/libpafe-ruby.html'
+license=('GPL2')
+depends=('libpafe' 'ruby')
+source=("http://homepage3.nifty.com/slokar/pasori/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('496b5f6299c14b6b11e4bd8fb1f2bd093ed75a6fee23635a1eb257b762e216cc')
+
+build() {
+ cd "${srcdir}/${pkgname}/"
+ if [ -f '.RUBYARCHDIR.time' ]; then
+ rm '.RUBYARCHDIR.time'
+ fi
+ ruby extconf.rb
+ make $MAKEFLAGS
+}
+
+check() {
+ cd "${srcdir}/${pkgname}/"
+ ruby -e 'require "./pasori.so"; puts "OKAY";'
+}
+
+package() {
+ cd "${srcdir}/${pkgname}/"
+ make DESTDIR="${pkgdir}" install
+}