summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4c860e24c96
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = libpaseto
+ pkgdesc = C implementation of PASETO (v2 tokens only)
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/authenticvision/libpaseto
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ depends = libsodium
+ source = https://github.com/authenticvision/libpaseto/archive/1.0.tar.gz
+ sha256sums = a0a2e830fb4d4116b4ffc78a72d96c8f9dff42aa226bb02681a0f4495069286a
+
+pkgname = libpaseto
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3bbeb7effbc5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: minus <minus@mnus.de>
+pkgname=libpaseto
+pkgver=1.0
+pkgrel=1
+pkgdesc="C implementation of PASETO (v2 tokens only)"
+arch=('x86_64')
+url="https://github.com/authenticvision/libpaseto"
+license=('MIT')
+depends=('libsodium')
+makedepends=('cmake')
+source=("https://github.com/authenticvision/$pkgname/archive/$pkgver.tar.gz")
+sha256sums=('a0a2e830fb4d4116b4ffc78a72d96c8f9dff42aa226bb02681a0f4495069286a')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cmake -B build -DCMAKE_INSTALL_PREFIX=/usr
+ make -C build
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ build/pasetotest
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make -C build DESTDIR="$pkgdir/" install
+}
+