summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f4ecb902358c..9ea0ced08b45 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = libphidget
- pkgdesc = user-space access library for the Phidget devices
- pkgver = 1.16.20230707
+ pkgdesc = User-space access library for the Phidget devices
+ pkgver = 1.17.20231004
pkgrel = 1
epoch = 2
url = https://www.phidgets.com
arch = x86_64
- license = LGPL3
+ license = BSD
+ depends = glibc
depends = libusb
provides = libphidget
conflicts = libphidget
- source = https://www.phidgets.com/downloads/phidget22/libraries/linux/libphidget22/libphidget22-1.16.20230707.tar.gz
- sha256sums = b48236d54ecf939aeacc18e575c665960dd46d247dec2997f3267700d6ec97e0
+ source = https://www.phidgets.com/downloads/phidget22/libraries/linux/libphidget22/libphidget22-1.17.20231004.tar.gz
+ sha256sums = 37e384e86b1f8044904c1ff7d00bdb16bb2b2be87a0962848a984981f457acf8
pkgname = libphidget
diff --git a/PKGBUILD b/PKGBUILD
index 14331936ab42..794d383df17f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=libphidget
-pkgver=1.16.20230707
+pkgver=1.17.20231004
pkgrel=1
epoch=2
url=https://www.phidgets.com
-pkgdesc="user-space access library for the Phidget devices"
+pkgdesc="User-space access library for the Phidget devices"
conflicts=('libphidget')
provides=('libphidget')
arch=('x86_64')
-license=('LGPL3')
-depends=('libusb')
+license=('BSD')
+depends=('glibc' 'libusb')
source=("https://www.phidgets.com/downloads/${pkgname#lib}22/libraries/linux/${pkgname}22/${pkgname}22-$pkgver.tar.gz")
-sha256sums=('b48236d54ecf939aeacc18e575c665960dd46d247dec2997f3267700d6ec97e0')
+sha256sums=('37e384e86b1f8044904c1ff7d00bdb16bb2b2be87a0962848a984981f457acf8')
build() {
cd ${pkgname}22-$pkgver
@@ -22,5 +22,6 @@ build() {
package() {
cd ${pkgname}22-$pkgver
- make DESTDIR="$pkgdir/" install
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING $pkgdir/usr/share/licenses/${pkgname}/COPYING
}