summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD33
2 files changed, 19 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 23e77b2249da..a0f2d6ccb6e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libreelec-creator-bin
pkgdesc = Allows you to install LibreELEC on a variety of devices.
pkgver = 1.3
- pkgrel = 2
+ pkgrel = 3
url = https://libreelec.tv/
arch = i686
arch = x86_64
@@ -9,14 +9,12 @@ pkgbase = libreelec-creator-bin
depends = bash
depends = gksu
provides = libreelec-creator-bin
+ source = https://github.com/LibreELEC/usb-sd-creator/raw/master/le_icon_256.png
+ sha256sums = 47636cc32d0140a4507a9b992e26f0955f68e0f6a06e8af93a4beb37de7cbcfe
source_i686 = http://releases.libreelec.tv/LibreELEC.USB-SD.Creator.Linux-32bit.bin
- source_i686 = https://github.com/LibreELEC/usb-sd-creator/raw/master/le_icon_256.png
sha256sums_i686 = 928373dbcafbd63357619137109672569203e979d71290ec58b1f01d6b5df85a
- sha256sums_i686 = 47636cc32d0140a4507a9b992e26f0955f68e0f6a06e8af93a4beb37de7cbcfe
source_x86_64 = http://releases.libreelec.tv/LibreELEC.USB-SD.Creator.Linux-64bit.bin
- source_x86_64 = https://github.com/LibreELEC/usb-sd-creator/raw/master/le_icon_256.png
sha256sums_x86_64 = ab867a4a0c4989877226269510138c51cb660cb10d728c795ed4343b6b0cf641
- sha256sums_x86_64 = 47636cc32d0140a4507a9b992e26f0955f68e0f6a06e8af93a4beb37de7cbcfe
pkgname = libreelec-creator-bin
diff --git a/PKGBUILD b/PKGBUILD
index 2bc725437438..b2789a1e0500 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgname="LibreELEC.USB-SD.Creator"
pkgname="libreelec-creator-bin"
pkgver="1.3"
-pkgrel="2"
+pkgrel="3"
pkgdesc="Allows you to install LibreELEC on a variety of devices."
arch=('i686' 'x86_64')
url="https://libreelec.tv/"
@@ -13,17 +13,16 @@ license=('GPL2')
depends=('bash' 'gksu')
provides=("${pkgname}")
-source_i686=("http://releases.libreelec.tv/${_pkgname}.Linux-32bit.bin"
- "https://github.com/LibreELEC/usb-sd-creator/raw/master/le_icon_256.png")
-source_x86_64=("http://releases.libreelec.tv/${_pkgname}.Linux-64bit.bin"
- "https://github.com/LibreELEC/usb-sd-creator/raw/master/le_icon_256.png")
-sha256sums_i686=('928373dbcafbd63357619137109672569203e979d71290ec58b1f01d6b5df85a'
- '47636cc32d0140a4507a9b992e26f0955f68e0f6a06e8af93a4beb37de7cbcfe')
-sha256sums_x86_64=('ab867a4a0c4989877226269510138c51cb660cb10d728c795ed4343b6b0cf641'
- '47636cc32d0140a4507a9b992e26f0955f68e0f6a06e8af93a4beb37de7cbcfe')
+source=("https://github.com/LibreELEC/usb-sd-creator/raw/master/le_icon_256.png")
+source_i686=("http://releases.libreelec.tv/${_pkgname}.Linux-32bit.bin")
+source_x86_64=("http://releases.libreelec.tv/${_pkgname}.Linux-64bit.bin")
+
+sha256sums=('47636cc32d0140a4507a9b992e26f0955f68e0f6a06e8af93a4beb37de7cbcfe')
+sha256sums_i686=('928373dbcafbd63357619137109672569203e979d71290ec58b1f01d6b5df85a')
+sha256sums_x86_64=('ab867a4a0c4989877226269510138c51cb660cb10d728c795ed4343b6b0cf641')
_LibreELEC="#!/usr/bin/sh
-exec gksudo /usr/share/${pkgname}/${_pkgname}.bin
+exec gksudo /opt/${pkgname}/${_pkgname}.bin
fi"
_LibreELEC_desktop="[Desktop Entry]
@@ -32,8 +31,8 @@ Version=1.0
Type=Application
Terminal=false
Name=LibreELEC USB-SD Creator
-Exec=/usr/share/${pkgname}/${_pkgname}
-Icon=/usr/share/${pkgname}/le_icon_256.png
+Exec=/opt/${pkgname}/${_pkgname}
+Icon=/opt/${pkgname}/le_icon_256.png
Categories=AudioVideo;Video;Player;TV;"
build() {
@@ -46,17 +45,17 @@ package() {
cd "${srcdir}"
# Data
- install -d ${pkgdir}/usr/share/${pkgname}
+ install -d ${pkgdir}/opt/${pkgname}
install -d ${pkgdir}/usr/share/applications
- install -m 755 ${_pkgname} "${pkgdir}/usr/share/${pkgname}/${_pkgname}"
- install -m 644 *.bin "${pkgdir}/usr/share/${pkgname}/${_pkgname}.bin"
- install -m 644 *.png "${pkgdir}/usr/share/${pkgname}/"
+ install -m 755 ${_pkgname} "${pkgdir}/opt/${pkgname}/${_pkgname}"
+ install -m 644 *.bin "${pkgdir}/opt/${pkgname}/${_pkgname}.bin"
+ install -m 644 *.png "${pkgdir}/opt/${pkgname}/"
# Desktop file
install -Dm 644 *.desktop "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
# Fix for permissions
- chmod +x ${pkgdir}/usr/share/${pkgname}/${_pkgname}.bin
+ chmod +x ${pkgdir}/opt/${pkgname}/${_pkgname}.bin
}
# vim:set ts=4 sw=4 ft=sh et: