summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f877a8848256
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libreoffice-extension-cleandoc
+ pkgdesc = remove hidden information from the document - macros, dialogs, form elements, user fields, etc.
+ pkgver = 0.6.7
+ pkgrel = 4
+ url = http://extensions.services.openoffice.org/project/cleandoc
+ arch = any
+ groups = libreoffice-extensions
+ license = LGPL
+ makedepends = unzip
+ depends = libreoffice
+ noextract = cleandoc-0.6.7.oxt
+ source = http://downloads.sourceforge.net/project/aoo-extensions/4798/1/cleandoc-0.6.7.oxt
+ md5sums = 27ac9e762f88b0d217662a90fe74a622
+
+pkgname = libreoffice-extension-cleandoc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd854ec29e84
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+#
+pkgname=libreoffice-extension-cleandoc
+_pkgname=cleandoc
+pkgver=0.6.7
+pkgrel=4
+pkgdesc="remove hidden information from the document - macros, dialogs, form elements, user fields, etc."
+arch=('any')
+url="http://extensions.services.openoffice.org/project/cleandoc"
+license=('LGPL')
+groups=('libreoffice-extensions')
+depends=('libreoffice')
+makedepends=('unzip')
+#source=('http://extensions.services.openoffice.org/e-files/4798/1/CleanDoc-0.6.7.oxt')
+source=("http://downloads.sourceforge.net/project/aoo-extensions/4798/1/${_pkgname}-${pkgver}.oxt")
+noextract=(${source[@]##*/})
+md5sums=('27ac9e762f88b0d217662a90fe74a622')
+
+package() {
+ _DESTDIR="${pkgdir}/usr/lib/libreoffice/share/extensions/${_pkgname}/"
+ install -dm755 "${_DESTDIR}"
+ unzip -q "$srcdir"/${_pkgname}-${pkgver}.oxt -d "${_DESTDIR}"
+# chmod -R g-w,o-w "${_DESTDIR}"
+
+# bsdtar -xf ${_pkgname}-${pkgver}.oxt -C "${_DESTDIR}"
+ chmod -R a=r,a+X,u+w "${_DESTDIR}"
+ chmod -R g-w,o-w "${_DESTDIR}"
+}
+