summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD11
-rw-r--r--unbundle-libs.patch9
3 files changed, 22 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33569d839f10..edc0f91cfd1a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libretro-genesis-plus-gx-wide-git
pkgdesc = Sega CD/Game Gear/Master System/Mega Drive/SG-1000 core
- pkgver = r1598.fa71a16
+ pkgver = r1609.04e9a4d
pkgrel = 1
url = https://github.com/libretro/Genesis-Plus-GX-Wide
arch = aarch64
@@ -12,15 +12,21 @@ pkgbase = libretro-genesis-plus-gx-wide-git
groups = libretro
license = custom
makedepends = git
+ makedepends = libchdr
+ makedepends = libvorbis
depends = glibc
- depends = libchdr
depends = libretro-core-info
- depends = libvorbis
+ depends = zlib
provides = libretro-genesis-plus-gx-wide
conflicts = libretro-genesis-plus-gx-wide
source = libretro-genesis-plus-gx-wide::git+https://github.com/libretro/Genesis-Plus-GX-Wide.git
source = unbundle-libs.patch
b2sums = SKIP
- b2sums = e56f791aeaf8650e777985780db8990603d5fc164a0cb6fcfe00a9a0d459be754f15a34ce73ebbb5a8a82cb7fedac34608616f7b05d2ccb9dfca0660cf828a3e
+ b2sums = ee0018de6c38382e4b6b95e71224d13001b9d13f808d09515c1f168f7255b5983b34842aeadb0fa0c9c47fac00c1196add9fd401f46b6e884b18fa26173a9419
pkgname = libretro-genesis-plus-gx-wide-git
+ depends = glibc
+ depends = libretro-core-info
+ depends = zlib
+ depends = libchdr.so
+ depends = libvorbisfile.so
diff --git a/PKGBUILD b/PKGBUILD
index ecb9c3fc9b18..f5d11736890a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Alexandre Bouvier <contact@amb.tf>
_pkgname=libretro-genesis-plus-gx-wide
pkgname=$_pkgname-git
-pkgver=r1598.fa71a16
+pkgver=r1609.04e9a4d
pkgrel=1
pkgdesc="Sega CD/Game Gear/Master System/Mega Drive/SG-1000 core"
arch=('aarch64' 'armv7h' 'i486' 'i686' 'pentium4' 'x86_64')
url="https://github.com/libretro/Genesis-Plus-GX-Wide"
license=('custom')
groups=('libretro')
-depends=('glibc' 'libchdr' 'libretro-core-info' 'libvorbis')
-makedepends=('git')
+depends=('glibc' 'libretro-core-info' 'zlib')
+makedepends=('git' 'libchdr' 'libvorbis')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=(
@@ -18,7 +18,7 @@ source=(
)
b2sums=(
'SKIP'
- 'e56f791aeaf8650e777985780db8990603d5fc164a0cb6fcfe00a9a0d459be754f15a34ce73ebbb5a8a82cb7fedac34608616f7b05d2ccb9dfca0660cf828a3e'
+ 'ee0018de6c38382e4b6b95e71224d13001b9d13f808d09515c1f168f7255b5983b34842aeadb0fa0c9c47fac00c1196add9fd401f46b6e884b18fa26173a9419'
)
pkgver() {
@@ -37,8 +37,9 @@ build() {
}
package() {
+ depends+=('libchdr.so' 'libvorbisfile.so')
cd $_pkgname
# shellcheck disable=SC2154
- install -Dm644 -t "$pkgdir"/usr/lib/libretro genesis_plus_gx_wide_libretro.so
+ install -D -t "$pkgdir"/usr/lib/libretro genesis_plus_gx_wide_libretro.so
install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname LICENSE.txt
}
diff --git a/unbundle-libs.patch b/unbundle-libs.patch
index 8113ef5c55e8..3c1e23370575 100644
--- a/unbundle-libs.patch
+++ b/unbundle-libs.patch
@@ -1,5 +1,5 @@
diff --git a/core/cd_hw/cdd.h b/core/cd_hw/cdd.h
-index f3e8002..f68c2b6 100644
+index b9bbf6b..c88b934 100644
--- a/core/cd_hw/cdd.h
+++ b/core/cd_hw/cdd.h
@@ -47,8 +47,8 @@
@@ -14,7 +14,7 @@ index f3e8002..f68c2b6 100644
#define cdd scd.cdd_hw
diff --git a/libretro/Makefile.common b/libretro/Makefile.common
-index a527d47..f8d99b2 100644
+index ac77aca..a0c0aa6 100644
--- a/libretro/Makefile.common
+++ b/libretro/Makefile.common
@@ -22,26 +22,8 @@ ifeq ($(HOOK_CPU), 1)
@@ -46,16 +46,19 @@ index a527d47..f8d99b2 100644
endif
SOURCES_C += $(foreach dir,$(GENPLUS_SRC_DIR),$(wildcard $(dir)/*.c))
-@@ -74,12 +56,6 @@ SOURCES_C += \
+@@ -74,13 +56,8 @@ SOURCES_C += \
$(LIBRETRO_COMM_DIR)/cdrom/cdrom.c \
$(LIBRETRO_COMM_DIR)/vfs/vfs_implementation_cdrom.c
endif
-SOURCES_C += \
- $(LIBRETRO_DEPS_DIR)/zlib-1.2.11/adler32.c \
+- $(LIBRETRO_DEPS_DIR)/zlib-1.2.11/crc32.c \
- $(LIBRETRO_DEPS_DIR)/zlib-1.2.11/inffast.c \
- $(LIBRETRO_DEPS_DIR)/zlib-1.2.11/inflate.c \
- $(LIBRETRO_DEPS_DIR)/zlib-1.2.11/inftrees.c \
- $(LIBRETRO_DEPS_DIR)/zlib-1.2.11/zutil.c
++INCFLAGS += $(shell pkg-config --cflags zlib)
++LIBS += $(shell pkg-config --libs zlib)
endif