aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rwxr-xr-xlibrewolf-cfg-comment-out-values.sh4
-rwxr-xr-xlibrewolf-cfg-uncomment-out-values.sh4
4 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60c5008fe4e2..ec60b0944b5e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = librewolf-comment-out-cfg-hook
pkgdesc = Comment out custom cfg values via pacman hook
pkgver = 1
- pkgrel = 4
+ pkgrel = 5
url = https://git.sr.ht/~freed00m/librewolf-comment-out-cfg-hook
arch = x86_64
arch = aarch64
diff --git a/PKGBUILD b/PKGBUILD
index e640237999be..75806ad0a852 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=librewolf-comment-out-cfg-hook
pkgver=1
-pkgrel=4
+pkgrel=5
pkgdesc='Comment out custom cfg values via pacman hook'
arch=(x86_64 aarch64)
url='https://git.sr.ht/~freed00m/librewolf-comment-out-cfg-hook'
diff --git a/librewolf-cfg-comment-out-values.sh b/librewolf-cfg-comment-out-values.sh
index ec4c3e03fead..86c8b4920dfb 100755
--- a/librewolf-cfg-comment-out-values.sh
+++ b/librewolf-cfg-comment-out-values.sh
@@ -11,7 +11,9 @@ touch $POLICY_MOD_FILE
while IFS= read -r line
do
- sed -i "s/^lockPref(\"$line\"/\/\/lockPref(\"$line\"/g" $CFG_FILE
+ sed -i -e "s/^lockPref(\"$line\"/\/\/lockPref(\"$line\"/g" \
+ -e "s/^defaultPref(\"$line\"/\/\/defaultPref(\"$line\"/g" \
+ $CFG_FILE
done < $CFG_MOD_FILE
diff --git a/librewolf-cfg-uncomment-out-values.sh b/librewolf-cfg-uncomment-out-values.sh
index 1d18f64cc4b6..92721af5a41d 100755
--- a/librewolf-cfg-uncomment-out-values.sh
+++ b/librewolf-cfg-uncomment-out-values.sh
@@ -8,7 +8,9 @@ CFG_MOD_FILE=/usr/lib/librewolf/librewolf.cfg-comment-out-list
while IFS= read -r line
do
- sed -i "s/\/\/lockPref(\"$line\"/lockPref(\"$line\"/g" $CFG_FILE
+ sed -i -e "s/\/\/lockPref(\"$line\"/lockPref(\"$line\"/g" \
+ -e "s/\/\/defaultPref(\"$line\"/defaultPref(\"$line\"/g" \
+ $CFG_FILE
done < $CFG_MOD_FILE
while IFS= read -r line