summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6dd6f50e22f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = librewolf-extension-uget-integration-bin
+ pkgdesc = Integrate LibreWolf with uGet download manager (binary release)
+ pkgver = 2.1.3.1
+ pkgrel = 1
+ url = https://addons.mozilla.org/addon/ugetintegration
+ arch = any
+ groups = librewolf-addons
+ license = GPL3
+ depends = librewolf
+ provides = librewolf-extension-uget-integration
+ conflicts = librewolf-extension-uget-integration
+ noextract = ugetintegration-2.1.3.1.xpi
+ source = https://addons.mozilla.org/firefox/downloads/file/911315/ugetintegration-2.1.3.1.xpi
+ sha256sums = 235f29ca5df79e4e5a338e29ef7cd721bb7873309b56364cc7a4bf4612e1ae85
+
+pkgname = librewolf-extension-uget-integration-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..280d3a3510cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: begin-theadventure <begin-thecontact.ncncb at dralias dot com>
+
+_pkgname=librewolf-extension-uget-integration
+pkgname=$_pkgname-bin
+pkgver=2.1.3.1
+pkgrel=1
+pkgdesc='Integrate LibreWolf with uGet download manager (binary release)'
+url="https://addons.mozilla.org/addon/ugetintegration"
+arch=('any')
+license=('GPL3')
+conflicts=($_pkgname)
+provides=($_pkgname)
+depends=('librewolf')
+groups=('librewolf-addons')
+noextract=("ugetintegration-$pkgver.xpi")
+source=("https://addons.mozilla.org/firefox/downloads/file/911315/ugetintegration-$pkgver.xpi")
+sha256sums=('235f29ca5df79e4e5a338e29ef7cd721bb7873309b56364cc7a4bf4612e1ae85')
+
+package() {
+ install -Dm644 ugetintegration-$pkgver.xpi "$pkgdir/usr/lib/librewolf/browser/extensions/uget-integration@slgobinath.xpi"
+}