summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b4bd662c43e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libtap-git
+ pkgdesc = C testing library implementing the Test Anything Protocol
+ pkgver = 0.1.0.16.gd2109aa
+ pkgrel = 1
+ url = https://github.com/zorgnax/libtap
+ arch = x86_64
+ arch = i686
+ license = LGPL
+ makedepends = git
+ depends = glibc
+ provides = libtap
+ conflicts = libtap
+ source = git+https://github.com/zorgnax/libtap
+ md5sums = SKIP
+
+pkgname = libtap-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..416428c6e712
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: John W. Trengrove <john@retrofilter.com>
+
+pkgname=libtap-git
+_pkgname=libtap
+pkgver=0.1.0.16.gd2109aa
+pkgrel=1
+pkgdesc="C testing library implementing the Test Anything Protocol"
+arch=('x86_64' 'i686')
+url="https://github.com/zorgnax/libtap"
+license=('LGPL')
+source=("git+https://github.com/zorgnax/libtap")
+depends=('glibc')
+makedepends=('git')
+conflicts=('libtap')
+provides=('libtap')
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${_pkgname}
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+build() {
+ cd ${_pkgname}
+ make
+}
+
+package() {
+ cd ${_pkgname}
+ make PREFIX="${pkgdir}/usr" install
+}