summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d9826479e476
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = libtga
+ pkgdesc = Lightweight library to read and write tga images
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = http://tgalib.sourceforge.net/
+ arch = x86_64
+ arch = i686
+ license = GPL
+ source = http://downloads.sourceforge.net/project/tgalib/libtga/1.0.1/libtga-1.0.1.tar.gz
+ sha1sums = 368d8667f1ca28075e92616c0856f1f28dc8103e
+
+pkgname = libtga
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23969951cc72
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Harry Jeffery <harry|@|exec64|.|co|.|uk>
+
+pkgname=libtga
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Lightweight library to read and write tga images"
+url="http://tgalib.sourceforge.net/"
+arch=('x86_64' 'i686')
+license=('GPL')
+source=("http://downloads.sourceforge.net/project/tgalib/libtga/${pkgver}/libtga-${pkgver}.tar.gz")
+sha1sums=('368d8667f1ca28075e92616c0856f1f28dc8103e')
+
+build() {
+ cd "${srcdir}/libtga-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/libtga-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim:set ts=2 sw=2 et: