summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD50
2 files changed, 21 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f9dfc6e508f..f6540a58aca1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,15 @@
pkgbase = libtree-git
pkgdesc = ldd as a tree with an option to bundle dependencies into a single folder
- pkgver = 1.0.4.r8.g02ee2b1
+ pkgver = 2.0.0.r161.g87ea31a
pkgrel = 1
url = https://github.com/haampie/libtree
arch = x86_64
license = MIT
- checkdepends = gtest
makedepends = git
- makedepends = cmake
- makedepends = cxxopts
- makedepends = termcolor
- makedepends = elfio
- depends = cppglob
depends = gcc-libs
- optdepends = binutils: For the --strip option
- optdepends = chrpath: For the --chrpath option
provides = libtree
conflicts = libtree
source = git+https://github.com/haampie/libtree.git
md5sums = SKIP
pkgname = libtree-git
-
diff --git a/PKGBUILD b/PKGBUILD
index a1e27582cebf..6102c2b2eeff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,57 +1,47 @@
# Maintainer: Otreblan <otreblain@gmail.com>
+# Contributor: Teodor Nikolov <teodor.nikolov22@gmail.com>
+# Contributor: Younes Khoudli <khoyobegenn@gmail.com>
pkgname=libtree-git
-pkgver=1.0.4.r8.g02ee2b1
+pkgver=2.0.0.r161.g87ea31a
pkgrel=1
pkgdesc="ldd as a tree with an option to bundle dependencies into a single folder "
arch=('x86_64')
url="https://github.com/haampie/libtree"
license=('MIT')
-depends=('cppglob' 'gcc-libs')
-makedepends=('git' 'cmake' 'cxxopts' 'termcolor' 'elfio')
-optdepends=('binutils: For the --strip option'
- 'chrpath: For the --chrpath option'
- )
-checkdepends=('gtest')
+depends=('gcc-libs')
+makedepends=('git')
+optdepends=()
+checkdepends=()
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=("git+$url.git")
md5sums=('SKIP')
-prepare() {
- mkdir -p "${pkgname%-git}/build"
-}
-
pkgver() {
- cd "$srcdir/${pkgname%-git}"
+ cd "$srcdir/${pkgname%-git}"
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/^v-\?//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/^v-\?//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
build() {
- cd "${pkgname%-git}/build" || exit 1
-
- cmake \
- -DUSE_SYSTEM_DEPS=ON \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_UNITY_BUILD=ON \
- -DCMAKE_INTERPROCEDURAL_OPTIMIZATION=ON \
- ..
- make
+ cd "${pkgname%-git}" || exit 1
+
+ make
}
check() {
- cd "${pkgname%-git}/build" || exit 1
+ cd "${pkgname%-git}" || exit 1
- make test
+ make check
}
package() {
- cd "${pkgname%-git}/build" || exit 1
+ cd "${pkgname%-git}" || exit 1
- make DESTDIR="$pkgdir/" install
- install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/${pkgname%-git}/LICENSE"
+ make PREFIX="$pkgdir/usr" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname%-git}/LICENSE"
}