summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD59
3 files changed, 50 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a95240e2c068..272fb77b39ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,9 @@
pkgbase = libulfius
- pkgdesc = HTTP Framework for REST API in C, using JSON, with websockets and streaming data
- pkgver = 2.6.9
- pkgrel = 2
- url = https://github.com/babelouest/ulfius
+ pkgver = 2.7.1
+ pkgrel = 1
+ url = http://babelouest.github.io/ulfius
arch = x86_64
- license = GPL
+ license = LGPL2.1
makedepends = git
makedepends = cmake
depends = libmicrohttpd
@@ -13,8 +12,14 @@ pkgbase = libulfius
depends = gnutls
depends = libgcrypt
depends = libyder
- source = git+https://github.com/babelouest/ulfius.git#tag=v2.6.9
- sha256sums = SKIP
+ source = ulfius-2.7.1.tar.gz::https://github.com/babelouest/ulfius/archive/v2.7.1.tar.gz
+ sha256sums = d5dfb90ac16fe9d8ce70fe6b23e43102d5208d4f0174196d3ef183d950d3a57b
pkgname = libulfius
+ pkgdesc = Web Framework for REST Applications in C
+ provides = libulfius.so=2.7
+
+pkgname = uwsc
+ pkgdesc = Ulfius WebSocket Client
+ depends = libulfius
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 85069bb52dde..be959e9d5475 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,42 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: Federico Di Pierro <nierro92@gmail.com>
-# Maintainer: Nathan Owens <ndowens @ artixlinux.org>
-pkgname=libulfius
+# Contributor: Nathan Owens <ndowens @ artixlinux.org
+pkgname=('libulfius' 'uwsc')
+pkgbase=libulfius
_gitname=ulfius
-pkgver=2.6.9
-pkgrel=2
-pkgdesc="HTTP Framework for REST API in C, using JSON, with websockets and streaming data"
-arch=(x86_64)
-url="https://github.com/babelouest/${_gitname}"
-license=(GPL)
+pkgver=2.7.1
+pkgrel=1
+arch=('x86_64')
+url="http://babelouest.github.io/ulfius"
+license=('LGPL2.1')
depends=('libmicrohttpd' 'jansson' 'curl' 'gnutls' 'libgcrypt' 'libyder')
makedepends=('git' 'cmake')
-source=("git+https://github.com/babelouest/ulfius.git#tag=v${pkgver}")
-sha256sums=('SKIP')
+source=("$_gitname-$pkgver.tar.gz::https://github.com/babelouest/ulfius/archive/v$pkgver.tar.gz")
+sha256sums=('d5dfb90ac16fe9d8ce70fe6b23e43102d5208d4f0174196d3ef183d950d3a57b')
-prepare() {
- cd "${srcdir}/${_gitname}"
- mkdir -p build
+build() {
+ cmake -B build -S "$_gitname-$pkgver" \
+ -G "Unix Makefiles" \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -Wno-dev
+ make -C build
}
-build() {
- cd "${srcdir}/${_gitname}"
- cmake -B build \
- -G "Unix Makefiles" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_BUILD_TYPE="Release"
- make -C build
+package_libulfius() {
+ pkgdesc="Web Framework for REST Applications in C"
+ provides=('libulfius.so=2.7')
+
+ make -C build DESTDIR="$pkgdir" install
+
+ rm -rf "$pkgdir"/usr/{bin,share/man}
}
-package() {
- cd "${srcdir}/${_gitname}"
- make -C build DESTDIR="$pkgdir" install
-
- # Remove conficts
- rm -rf "$pkgdir"/usr/include/{orcania.h,orcania-cfg.h,yder-cfg.h,yder.h}
- rm -rf "$pkgdir"/usr/lib/{liborcania.so*,liborcania.so.*,libyder.so*,libyder.so.*,pkgconfig/{liborcania.pc,libyder.pc}}
+package_uwsc() {
+ pkgdesc="Ulfius WebSocket Client"
+ depends=('libulfius')
+
+ make -C build DESTDIR="$pkgdir" install
+ rm -rf "$pkgdir"/usr/{include,lib,share/doc}
}