summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD64
2 files changed, 40 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 77351132b76f..646efd479ee4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = libunwind-git
pkgdesc = Portable and efficient C programming interface (API) to determine the call-chain of a program
- pkgver = v1.5+rc1+44+gf1cee65e
+ pkgver = 1.7.2.r146.g24dc3b08
pkgrel = 1
url = https://www.nongnu.org/libunwind/
+ arch = i686
arch = x86_64
- license = GPL
+ license = MIT
+ makedepends = git
makedepends = texlive-core
depends = glibc
depends = xz
- provides = libunwind
+ depends = zlib
+ provides = libunwind=1.7.2.r146.g24dc3b08
conflicts = libunwind
+ options = staticlibs
source = git+https://github.com/libunwind/libunwind.git
- validpgpkeys = SKIP
- validpgpkeys = SKIP
- sha512sums = SKIP
+ sha256sums = SKIP
pkgname = libunwind-git
-
diff --git a/PKGBUILD b/PKGBUILD
index e51d74fec31f..b041b78920fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+# Previous maintainer: Vincent Grande <shoober420@gmail.com>
# Contributor: Felix Yan <felixonmars@archlinux.org>
# Contributor: S\u00e9bastien Luttringer
# Contributor: Lawrence Lee <valheru@facticius.net>
@@ -6,49 +7,48 @@
# Contributor: keystone <phillip.marvin@gmail.com>
pkgname=libunwind-git
-pkgver=v1.5+rc1+44+gf1cee65e
+pkgver=1.7.2.r146.g24dc3b08
pkgrel=1
-pkgdesc='Portable and efficient C programming interface (API) to determine the call-chain of a program'
-arch=('x86_64')
-url='https://www.nongnu.org/libunwind/'
-license=('GPL')
-depends=('glibc' 'xz')
-provides=(libunwind)
-conflicts=(libunwind)
-makedepends=('texlive-core')
+pkgdesc="Portable and efficient C programming interface (API) to determine the call-chain of a program"
+arch=('i686' 'x86_64')
+url="https://www.nongnu.org/libunwind/"
+license=('MIT')
+depends=('glibc' 'xz' 'zlib')
+makedepends=('git' 'texlive-core')
+provides=("libunwind=$pkgver")
+conflicts=('libunwind')
+options=('staticlibs')
source=("git+https://github.com/libunwind/libunwind.git")
-sha512sums=('SKIP')
-validpgpkeys=('SKIP' # Arun Sharma
- 'SKIP') # Dave Watson
+sha256sums=('SKIP')
-pkgver() {
- cd libunwind
- git describe --tags | sed 's/-/+/g'
-}
-prepare() {
- cd libunwind
+pkgver() {
+ cd "libunwind"
- NOCONFIGURE=1 ./autogen.sh
+ _tag=$(git tag -l --sort -v:refname | grep -E '^v?[0-9\.]+$' | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//'
}
build() {
- cd libunwind
-# CFLAGS+=' -fcommon' # https://wiki.gentoo.org/wiki/Gcc_10_porting_notes/fno_common
- ./configure --prefix=/usr
+ cd "libunwind"
+
+ autoreconf -fi
+ ./configure \
+ --prefix="/usr"
make
}
-#check() {
-# cd libunwind
- # This function is ``supposed'' to fail. Upstream know, but haven't fixed it.
-# make check || :
-#}
+check() {
+ cd "libunwind"
-package() {
- cd libunwind
- make DESTDIR="$pkgdir" install
+ make check
}
-# vim:set ts=2 sw=2 et:
+package() {
+ cd "libunwind"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "COPYING" -t "$pkgdir/usr/share/licenses/libunwind"
+}