summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD51
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8925cb42f52b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libx32-tk
+ pkgdesc = A windowing toolkit for use with tcl
+ pkgver = 8.6.4
+ pkgrel = 1.1
+ url = http://tcl.sourceforge.net/
+ arch = x86_64
+ license = custom
+ depends = libx32-tcl=8.6.4
+ depends = libx32-libxss
+ depends = libx32-libxft
+ depends = tk
+ options = staticlibs
+ source = http://downloads.sourceforge.net/sourceforge/tcl/tk8.6.4-src.tar.gz
+ sha1sums = ad24c59ac2e7453d1ed2bad0d7d18a01eabc5226
+
+pkgname = libx32-tk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..89d9608e264d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# $Id: PKGBUILD 220811 2014-08-30 02:45:43Z eric $
+# Maintainer: Eric BĂ©langer <eric@archlinux.org>
+
+pkgname=libx32-tk
+pkgver=8.6.4
+pkgrel=1.1
+pkgdesc="A windowing toolkit for use with tcl"
+arch=('x86_64')
+url="http://tcl.sourceforge.net/"
+license=('custom')
+depends=("libx32-tcl=${pkgver}" 'libx32-libxss' 'libx32-libxft' 'tk')
+options=('staticlibs')
+source=(http://downloads.sourceforge.net/sourceforge/tcl/tk${pkgver}-src.tar.gz)
+sha1sums=('ad24c59ac2e7453d1ed2bad0d7d18a01eabc5226')
+
+build() {
+ cd tk${pkgver}/unix
+ export CC='gcc -mx32'
+ export CXX='g++ -mx32'
+ export PKG_CONFIG_PATH="/usr/libx32/pkgconfig"
+ export LDFLAGS+='-L/usr/libx32'
+ ./configure --prefix=/usr --mandir=/usr/share/man \
+ --enable-threads --disable-rpath \
+ --libdir=/usr/libx32 \
+ --libexecdir=/usr/libx32 \
+ --with-tcl=/usr/libx32/
+ make
+}
+
+check() {
+ cd tk${pkgver}/unix
+ # make test
+}
+
+package() {
+ cd tk${pkgver}/unix
+ make INSTALL_ROOT="${pkgdir}" install install-private-headers
+ mv "${pkgdir}/usr/bin/wish${pkgver%.*}" \
+ "${pkgdir}/usr/bin/wish${pkgver%.*}-x32"
+ ln -sf wish${pkgver%.*}-x32 "${pkgdir}/usr/bin/wish-x32"
+ ln -sf libtk${pkgver%.*}.so "${pkgdir}/usr/libx32/libtk.so"
+
+ rm -rf "${pkgdir}/usr/"{share/man,include,lib}
+
+ install -Dm644 license.terms "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # remove buildroot traces
+ sed -e "s#${srcdir}/tk${pkgver}/unix#/usr/libx32#" \
+ -e "s#${srcdir}/tk${pkgver}#/usr/include#" \
+ -i "${pkgdir}/usr/libx32/tkConfig.sh"
+}