summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD22
2 files changed, 12 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a6c76a1b1a0f..933f4a43d6fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libxtract-git
- pkgdesc = A simple, portable, lightweight library of audio feature extraction functions
- pkgver = 0.159.b8c8c2c
+ pkgdesc = simple, portable, lightweight library of audio feature extraction functions
+ pkgver = 0.282.7aa96fa
pkgrel = 1
url = https://github.com/jamiebullock/LibXtract
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index c9e451bc9ed6..44e0e592871a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
-# Maintainer: Felix Yan <felixonmars@gmail.com>
+# Contributor: Felix Yan <felixonmars@gmail.com>
pkgname=libxtract-git
_gitname=LibXtract
-pkgver=0.159.b8c8c2c
+pkgver=0.282.7aa96fa
pkgrel=1
-pkgdesc='A simple, portable, lightweight library of audio feature extraction functions'
+pkgdesc='simple, portable, lightweight library of audio feature extraction functions'
url='https://github.com/jamiebullock/LibXtract'
arch=('i686' 'x86_64')
license=('custom')
@@ -16,20 +16,18 @@ source=("git://github.com/jamiebullock/LibXtract.git")
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/$_gitname"
+ cd "$_gitname"
echo "0.$(git rev-list --count HEAD).$(git describe --always)"
}
build() {
- cd "$srcdir/$_gitname"
- sh autogen.sh
- ./configure --prefix='/usr' # --enable-pd_example
- make
+ cd "$_gitname"
+ make LIBRARY=shared
}
-package ()
-{
- cd "$srcdir/$_gitname"
- make DESTDIR="$pkgdir" install
+
+package () {
+ cd "$_gitname"
+ make PREFIX="$pkgdir/usr" LIBRARY=shared install
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}