summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--.nvchecker.toml5
-rw-r--r--PKGBUILD27
3 files changed, 25 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f34f7f5f2fa8..48a1bff32090 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,15 @@
pkgbase = lightnovel-crawler-bin
- pkgdesc = An app to download novels from online sources and generate e-books.
- pkgver = 2.26.3
- pkgrel = 6
- url = https://github.com/dipu-bd/lightnovel-crawler.git
- arch = any
- license = Apache
+ pkgdesc = An app to download novels from online sources and generate e-books (standalone bundle)
+ pkgver = 3.7.4
+ pkgrel = 1
+ url = https://github.com/dipu-bd/lightnovel-crawler
+ arch = x86_64
+ license = Apache-2.0
depends = zlib
optdepends = calibre: Output suport for docx, mobi, pdf, rtf, azw3, txt, fb2, lit, lrf, oeb, pdb, rb, snb, tcr
provides = lncrawl
conflicts = lncrawl
- source = https://github.com/dipu-bd/lightnovel-crawler/releases/download/v2.26.3/lncrawl-2.26.3-linux
- md5sums = 033f1f00a8588eecf67546ef201fe7aa
- sha1sums = 6abbdc56c43459bfb2b7846a1678d86303666613
- sha256sums = 72ba156a06082964523c400476d23558e3ab39416341f01a4ca079295ec29199
+ source = https://github.com/dipu-bd/lightnovel-crawler/releases/download/v3.7.4/lncrawl
+ sha256sums = 40eb7188af0d282fb73febfa2cd9b0751674ea1c5006465aae2412ba01cc714e
pkgname = lightnovel-crawler-bin
-
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..454a491e3ab6
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,5 @@
+[lightnovel-crawler-bin]
+source = "github"
+github = "dipu-bd/lightnovel-crawler"
+use_latest_release = true
+prefix = "v"
diff --git a/PKGBUILD b/PKGBUILD
index b074e0716616..6b5bb0bbf92d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,20 @@
-# Maintainer: Robert Manning <duckz@protonmail.ch>
+# Maintainer: Bastien Traverse <neitsab@archlinux.org>
+# Contributor: Robert Manning <duckz@protonmail.ch>
pkgname=lightnovel-crawler-bin
-pkgver=2.26.3
-pkgrel=6
-pkgdesc="An app to download novels from online sources and generate e-books."
-arch=('any')
-url="https://github.com/dipu-bd/lightnovel-crawler.git"
-license=('Apache')
-depends=(zlib)
+pkgver=3.7.4
+pkgrel=1
+pkgdesc="An app to download novels from online sources and generate e-books (standalone bundle)"
+arch=('x86_64')
+url="https://github.com/dipu-bd/lightnovel-crawler"
+license=('Apache-2.0')
+depends=('zlib')
optdepends=('calibre: Output suport for docx, mobi, pdf, rtf, azw3, txt, fb2, lit, lrf, oeb, pdb, rb, snb, tcr')
provides=(lncrawl)
conflicts=(lncrawl)
-
-source=("https://github.com/dipu-bd/lightnovel-crawler/releases/download/v$pkgver/lncrawl-$pkgver-linux")
-md5sums=('033f1f00a8588eecf67546ef201fe7aa')
-sha1sums=('6abbdc56c43459bfb2b7846a1678d86303666613')
-sha256sums=('72ba156a06082964523c400476d23558e3ab39416341f01a4ca079295ec29199')
-
+source=("${url}/releases/download/v$pkgver/lncrawl")
+sha256sums=('40eb7188af0d282fb73febfa2cd9b0751674ea1c5006465aae2412ba01cc714e')
package() {
- install -Dm755 ${startdir}/lncrawl-$pkgver-linux ${pkgdir}/usr/bin/lncrawl
+ install -Dm755 ${srcdir}/lncrawl ${pkgdir}/usr/bin/lncrawl
}