summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD32
2 files changed, 13 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 56ebf8a9d5d7..b2902a9d5865 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = lighttpd2-git
pkgdesc = The new Lighty: A small, secure, scalable, flexible webserver
- pkgver = 1623.29e57d3
+ pkgver = 1668.c673e5b
pkgrel = 1
url = http://redmine.lighttpd.net/wiki/lighttpd2/
install = lighttpd2.install
arch = i686
arch = x86_64
license = MIT
- makedepends = pkg-config
+ makedepends = meson
makedepends = git
depends = libev
depends = ragel
diff --git a/PKGBUILD b/PKGBUILD
index 20b94579205c..2018bb50ab7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Georg Nagel <g.schlmm at gmail dot com>
pkgname=lighttpd2-git
-pkgver=1623.29e57d3
+pkgver=1668.c673e5b
pkgrel=1
pkgdesc="The new Lighty: A small, secure, scalable, flexible webserver"
arch=(i686 x86_64)
@@ -11,7 +11,7 @@ provides=('lighttpd2')
conflicts=('lighttpd2')
depends=("libev" "ragel" "lua51" "zlib" "bzip2" "openssl" "glib2" "libidn" "libunwind")
optdepends=("valgrind: for deep debuggins")
-makedepends=("pkg-config" "git")
+makedepends=("meson" "git")
backup=('etc/lighttpd2/lighttpd.conf' 'etc/lighttpd2/angel.conf' 'etc/lighttpd2/mimetypes.conf')
install=lighttpd2.install
source=("${pkgname}"::"git+https://git.lighttpd.net/lighttpd/lighttpd2.git")
@@ -22,36 +22,26 @@ pkgver() {
echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
}
+prepare() {
+ cd $pkgname
+}
+
build() {
- cd "${srcdir}/${pkgname}"
-
export LUA_LIBS=$(pkg-config --libs lua51)
export LUA_CFLAGS=$(pkg-config --cflags lua51)
- ./autogen.sh
- ./configure \
- --prefix=/usr \
- --sbindir=/usr/bin \
- --libexecdir=/usr/lib/lighttpd-2.0.0 \
- --with-pid-dir=/run \
- --with-lua \
- --with-openssl \
- --with-kerberos5 \
- --with-zlib \
- --with-bzip2 \
- --includedir=/usr/include/lighttpd-2.0.0
-
- make
- sed -i -e 's/^docroot "\/var\/www";/docroot "\/srv\/http";/' contrib/lighttpd.conf
+ arch-meson build $pkgname --libexecdir=lib/lighttpd-2.0.0
+ meson compile -C build
}
package() {
- cd "${srcdir}/${pkgname}"
- make DESTDIR="$pkgdir/" install
+ meson install -C build --destdir "$pkgdir"
install -D -d "$pkgdir/etc/sv/lighttpd2"
install -D -d "$pkgdir/var/log/lighttpd2"
+ cd "${srcdir}/${pkgname}"
install -D -m0644 contrib/lighttpd.conf "$pkgdir/etc/lighttpd2/lighttpd.conf"
+ sed -i -e 's/^docroot "\/var\/www";/docroot "\/srv\/http";/' $pkgdir/etc/lighttpd2/lighttpd.conf
install -D -m0644 contrib/angel.conf "$pkgdir/etc/lighttpd2/angel.conf"
install -D -m0644 contrib/mimetypes.conf "$pkgdir/etc/lighttpd2/mimetypes.conf"
install -D -m0644 contrib/systemd/lighttpd2.service "$pkgdir/usr/lib/systemd/system/lighttpd2.service"