summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
-rw-r--r--fix_build.patch44
3 files changed, 6 insertions, 66 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ecac46bfaeb2..0e0a84f050c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lingot
pkgdesc = A musical instrument tuner
- pkgver = 1.1.0
+ pkgver = 1.1.1
pkgrel = 1
url = http://www.nongnu.org/lingot/
arch = i686
@@ -9,12 +9,8 @@ pkgbase = lingot
makedepends = perl-xml-parser
makedepends = intltool
depends = gtk3
- source = https://download.savannah.gnu.org/releases/lingot/lingot-1.1.0.tar.gz
- source = https://github.com/ibancg/lingot/commit/d47be66c4ea0ab2967aa1cb7c4f8e3daf0c7786f.patch
- source = fix_build.patch
- sha256sums = 78bb5c5ab6dc0a8fb223b377ec029e1a3e2227ea8d3a0eb54e7ad500b69c7818
- sha256sums = 0b82e5473ca4b8b9d7bf6ab0c22d8f1c458d1dbad34a92cf2f4183873174765c
- sha256sums = f728003d62a4943dd00842b6cfbb27d5b61e9c7b4db97238046022fb3e915c79
+ source = https://download.savannah.gnu.org/releases/lingot/lingot-1.1.1.tar.gz
+ sha256sums = c4f97e496a3666c70786d136e6f2ccc5e8a3813eb08cda35cacd7eb0d16f4d56
pkgname = lingot
diff --git a/PKGBUILD b/PKGBUILD
index 7cb0d1304faa..ee4f213ccced 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Sergio Montesinos <sermonpe@yahoo.es>
pkgname=lingot
-pkgver=1.1.0
+pkgver=1.1.1
pkgrel=1
pkgdesc='A musical instrument tuner'
url='http://www.nongnu.org/lingot/'
@@ -10,21 +10,9 @@ license=('GPL')
arch=('i686' 'x86_64')
depends=('gtk3')
makedepends=('perl-xml-parser' 'intltool')
-source=("https://download.savannah.gnu.org/releases/lingot/$pkgname-$pkgver.tar.gz"
- 'https://github.com/ibancg/lingot/commit/d47be66c4ea0ab2967aa1cb7c4f8e3daf0c7786f.patch'
- 'fix_build.patch')
+source=("https://download.savannah.gnu.org/releases/lingot/$pkgname-$pkgver.tar.gz")
-sha256sums=('78bb5c5ab6dc0a8fb223b377ec029e1a3e2227ea8d3a0eb54e7ad500b69c7818'
- '0b82e5473ca4b8b9d7bf6ab0c22d8f1c458d1dbad34a92cf2f4183873174765c'
- 'f728003d62a4943dd00842b6cfbb27d5b61e9c7b4db97238046022fb3e915c79')
-
-prepare() {
- cd "$pkgname-$pkgver"
- # Fix JACK
- patch -p1 -i "$srcdir/d47be66c4ea0ab2967aa1cb7c4f8e3daf0c7786f.patch"
- # Fix build: combines two patches without bumping version https://github.com/ibancg/lingot/commit/14ff1d2c872b304be04aabcfc7a51cdefed43293.patch https://github.com/ibancg/lingot/commit/e6debb9e29fec0051251dfd61e1d88779b207218.patch
- patch -p1 -i "$srcdir/fix_build.patch"
-}
+sha256sums=('c4f97e496a3666c70786d136e6f2ccc5e8a3813eb08cda35cacd7eb0d16f4d56')
build() {
cd "$pkgname-$pkgver"
diff --git a/fix_build.patch b/fix_build.patch
deleted file mode 100644
index fd252845b569..000000000000
--- a/fix_build.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff '--color=auto' -aur lingot-1.1.0/src/lingot-io-config.c lingot-1.1.0.patched/src/lingot-io-config.c
---- lingot-1.1.0/src/lingot-io-config.c 2020-05-09 07:47:13.000000000 +1000
-+++ lingot-1.1.0.patched/src/lingot-io-config.c 2020-05-10 20:12:32.983667136 +1000
-@@ -638,7 +638,7 @@
- }
-
- json_object* obj = NULL;
-- json_bool ok = TRUE;
-+ json_bool ok = 1;
-
- ok = json_object_object_get_ex(doc, "VERSION", &obj);
- if (!ok) {
-@@ -799,7 +799,7 @@
- scale.offset_cents[i] = double_value;
- scale.offset_ratios[0][i] = -1;
- scale.offset_ratios[1][i] = -1;
-- ok = TRUE;
-+ ok = 1;
- } else {
- string_value = json_object_get_string(value);
- ok = lingot_config_scale_parse_shift((char*) string_value,
-diff '--color=auto' -aur lingot-1.1.0/src/lingot-io-ui-settings.c lingot-1.1.0.patched/src/lingot-io-ui-settings.c
---- lingot-1.1.0/src/lingot-io-ui-settings.c 2020-05-03 19:53:06.000000000 +1000
-+++ lingot-1.1.0.patched/src/lingot-io-ui-settings.c 2020-05-10 20:12:39.310303906 +1000
-@@ -35,8 +35,8 @@
- {
- // default values
- ui_settings.app_version = NULL;
-- ui_settings.spectrum_visible = TRUE;
-- ui_settings.gauge_visible = TRUE;
-+ ui_settings.spectrum_visible = 1;
-+ ui_settings.gauge_visible = 1;
- ui_settings.win_pos_x = -1;
- ui_settings.win_pos_y = -1;
- ui_settings.win_width = 480;
-@@ -60,7 +60,7 @@
- }
-
- json_object* obj;
-- json_bool ok = TRUE;
-+ json_bool ok = 1;
-
- ok = json_object_object_get_ex(doc, "appVersion", &obj);
- if (ok) {