summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--5012_enable-cpu-optimizations-for-gcc91.patch51
-rw-r--r--PKGBUILD8
-rw-r--r--config.x86_642
4 files changed, 38 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b70d4b2dc4e2..1b40165bb6ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-amd
- pkgver = 5.7.v.7
+ pkgver = 5.7.v.8
pkgrel = 1
url = https://www.kernel.org/
arch = x86_64
@@ -18,9 +18,9 @@ pkgbase = linux-amd
source = 5012_enable-cpu-optimizations-for-gcc91.patch
source = asusbat.patch
sha256sums = SKIP
- sha256sums = 105d845c64375928491c9815c566b5436963200a7a26fdc285c7f9e2b3a5fc50
+ sha256sums = 6982df59ce6c1f7cc1c1eb2d4a66570a0d05123ee138dfcc598342586c1db224
sha256sums = 71caf34adf69e9e2567a38cfc951d1c60b13dbe87f58a9acfeb3fe48ffdc9d08
- sha256sums = 86f0ec5779107e06844dfbd8278b6b44672c2065a4b94151b9454292e4a1b0f0
+ sha256sums = 37b801cd6d3fdd205fcd18676bd0f399ae6558fb5d074f1710f8464c8034482c
sha256sums = 93d24cbf50a3f9920bbdc2b07f7f665672089e2d7eda897ffba0587d6cf9ab51
pkgname = linux-amd
diff --git a/5012_enable-cpu-optimizations-for-gcc91.patch b/5012_enable-cpu-optimizations-for-gcc91.patch
index 049ec12608cd..2f161538e06a 100644
--- a/5012_enable-cpu-optimizations-for-gcc91.patch
+++ b/5012_enable-cpu-optimizations-for-gcc91.patch
@@ -42,14 +42,18 @@ It also offers to compile passing the 'native' option which, "selects the CPU
to generate code for at compilation time by determining the processor type of
the compiling machine. Using -march=native enables all instruction subsets
supported by the local machine and will produce code optimized for the local
-machine under the constraints of the selected instruction set."[3]
+machine under the constraints of the selected instruction set."[2]
+
+Do NOT try using the 'native' option on AMD Piledriver, Steamroller, or
+Excavator CPUs (-march=bdver{2,3,4} flag). The build will error out due the
+kernel's objtool issue with these.[3a,b]
MINOR NOTES
This patch also changes 'atom' to 'bonnell' in accordance with the gcc v4.9
changes. Note that upstream is using the deprecated 'match=atom' flags when I
-believe it should use the newer 'march=bonnell' flag for atom processors.[2]
+believe it should use the newer 'march=bonnell' flag for atom processors.[4]
-It is not recommended to compile on Atom-CPUs with the 'native' option.[4] The
+It is not recommended to compile on Atom-CPUs with the 'native' option.[5] The
recommendation is to use the 'atom' option instead.
BENEFITS
@@ -61,21 +65,23 @@ https://github.com/graysky2/kernel_gcc_patch
REQUIREMENTS
linux version >=5.7
-gcc version >=9.1
+gcc version >=9.1 and <10
ACKNOWLEDGMENTS
-This patch builds on the seminal work by Jeroen.[5]
+This patch builds on the seminal work by Jeroen.[6]
REFERENCES
-1. https://gcc.gnu.org/gcc-4.9/changes.html
-2. https://bugzilla.kernel.org/show_bug.cgi?id=77461
-3. https://gcc.gnu.org/onlinedocs/gcc/x86-Options.html
-4. https://github.com/graysky2/kernel_gcc_patch/issues/15
-5. http://www.linuxforge.net/docs/linux/linux-gcc.php
+1. https://gcc.gnu.org/gcc-4.9/changes.html
+2. https://gcc.gnu.org/onlinedocs/gcc/x86-Options.html
+3a. https://gcc.gnu.org/bugzilla/show_bug.cgi?id=95671#c11
+3b. https://github.com/graysky2/kernel_gcc_patch/issues/55
+4. https://bugzilla.kernel.org/show_bug.cgi?id=77461
+5. https://github.com/graysky2/kernel_gcc_patch/issues/15
+6. http://www.linuxforge.net/docs/linux/linux-gcc.php
---- a/arch/x86/include/asm/vermagic.h 2019-12-15 18:16:08.000000000 -0500
-+++ b/arch/x86/include/asm/vermagic.h 2019-12-17 14:03:55.968871551 -0500
-@@ -27,6 +27,36 @@ struct mod_arch_specific {
+--- a/arch/x86/include/asm/vermagic.h 2020-06-10 14:21:45.000000000 -0400
++++ b/arch/x86/include/asm/vermagic.h 2020-06-15 10:44:10.437477053 -0400
+@@ -17,6 +17,36 @@
#define MODULE_PROC_FAMILY "586MMX "
#elif defined CONFIG_MCORE2
#define MODULE_PROC_FAMILY "CORE2 "
@@ -112,7 +118,7 @@ REFERENCES
#elif defined CONFIG_MATOM
#define MODULE_PROC_FAMILY "ATOM "
#elif defined CONFIG_M686
-@@ -45,6 +75,28 @@ struct mod_arch_specific {
+@@ -35,6 +65,28 @@
#define MODULE_PROC_FAMILY "K7 "
#elif defined CONFIG_MK8
#define MODULE_PROC_FAMILY "K8 "
@@ -141,8 +147,8 @@ REFERENCES
#elif defined CONFIG_MELAN
#define MODULE_PROC_FAMILY "ELAN "
#elif defined CONFIG_MCRUSOE
---- a/arch/x86/Kconfig.cpu 2019-12-15 18:16:08.000000000 -0500
-+++ b/arch/x86/Kconfig.cpu 2019-12-17 14:09:03.805642284 -0500
+--- a/arch/x86/Kconfig.cpu 2020-06-10 14:21:45.000000000 -0400
++++ b/arch/x86/Kconfig.cpu 2020-06-15 10:44:10.437477053 -0400
@@ -123,6 +123,7 @@ config MPENTIUMM
config MPENTIUM4
bool "Pentium-4/Celeron(P4-based)/Pentium-4 M/older Xeon"
@@ -524,9 +530,9 @@ REFERENCES
config X86_MINIMUM_CPU_FAMILY
int
---- a/arch/x86/Makefile 2019-12-15 18:16:08.000000000 -0500
-+++ b/arch/x86/Makefile 2019-12-17 14:03:55.972204960 -0500
-@@ -119,13 +119,53 @@ else
+--- a/arch/x86/Makefile 2020-06-10 14:21:45.000000000 -0400
++++ b/arch/x86/Makefile 2020-06-15 10:44:35.608035680 -0400
+@@ -119,13 +119,56 @@ else
KBUILD_CFLAGS += $(call cc-option,-mskip-rax-setup)
# FIXME - should be integrated in Makefile.cpu (Makefile_32.cpu)
@@ -539,8 +545,11 @@ REFERENCES
+ cflags-$(CONFIG_MJAGUAR) += $(call cc-option,-march=btver2)
+ cflags-$(CONFIG_MBULLDOZER) += $(call cc-option,-march=bdver1)
+ cflags-$(CONFIG_MPILEDRIVER) += $(call cc-option,-march=bdver2)
++ cflags-$(CONFIG_MPILEDRIVER) += $(call cc-option,-mno-tbm)
+ cflags-$(CONFIG_MSTEAMROLLER) += $(call cc-option,-march=bdver3)
++ cflags-$(CONFIG_MSTEAMROLLER) += $(call cc-option,-mno-tbm)
+ cflags-$(CONFIG_MEXCAVATOR) += $(call cc-option,-march=bdver4)
++ cflags-$(CONFIG_MEXCAVATOR) += $(call cc-option,-mno-tbm)
+ cflags-$(CONFIG_MZEN) += $(call cc-option,-march=znver1)
+ cflags-$(CONFIG_MZEN2) += $(call cc-option,-march=znver2)
cflags-$(CONFIG_MPSC) += $(call cc-option,-march=nocona)
@@ -583,8 +592,8 @@ REFERENCES
cflags-$(CONFIG_GENERIC_CPU) += $(call cc-option,-mtune=generic)
KBUILD_CFLAGS += $(cflags-y)
---- a/arch/x86/Makefile_32.cpu 2019-12-15 18:16:08.000000000 -0500
-+++ b/arch/x86/Makefile_32.cpu 2019-12-17 14:03:55.972204960 -0500
+--- a/arch/x86/Makefile_32.cpu 2020-06-10 14:21:45.000000000 -0400
++++ b/arch/x86/Makefile_32.cpu 2020-06-15 10:44:10.437477053 -0400
@@ -24,7 +24,19 @@ cflags-$(CONFIG_MK6) += -march=k6
# Please note, that patches that add -march=athlon-xp and friends are pointless.
# They make zero difference whatsosever to performance at this time.
diff --git a/PKGBUILD b/PKGBUILD
index 7cdf2d5415cd..7d029d14a219 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgbase=linux-amd
_srcname=linux
-gitver=v5.7.7
-pkgver=5.7.v.7
+gitver=v5.7.8
+pkgver=5.7.v.8
pkgrel=1
arch=('x86_64')
url="https://www.kernel.org/"
@@ -26,11 +26,11 @@ source=('git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git'
)
sha256sums=('SKIP'
#config.x86_64
- '105d845c64375928491c9815c566b5436963200a7a26fdc285c7f9e2b3a5fc50'
+ '6982df59ce6c1f7cc1c1eb2d4a66570a0d05123ee138dfcc598342586c1db224'
#.preset file
'71caf34adf69e9e2567a38cfc951d1c60b13dbe87f58a9acfeb3fe48ffdc9d08'
#patch gentoo
- '86f0ec5779107e06844dfbd8278b6b44672c2065a4b94151b9454292e4a1b0f0'
+ '37b801cd6d3fdd205fcd18676bd0f399ae6558fb5d074f1710f8464c8034482c'
#asusbat.patch
'93d24cbf50a3f9920bbdc2b07f7f665672089e2d7eda897ffba0587d6cf9ab51'
)
diff --git a/config.x86_64 b/config.x86_64
index 17f349fa9030..9c116afcefcf 100644
--- a/config.x86_64
+++ b/config.x86_64
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.7.7 Kernel Configuration
+# Linux/x86 5.7.8 Kernel Configuration
#
#