summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3bd8bbcf387c..303cb84f67e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-amd
pkgver = 5.7.v.11
- pkgrel = 1
+ pkgrel = 2
url = https://www.kernel.org/
arch = x86_64
license = GPL2
@@ -15,11 +15,13 @@ pkgbase = linux-amd
source = git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git
source = config.x86_64
source = linux-amd.preset
+ source = linux.install
source = 5013_enable-cpu-optimizations-for-gcc10.patch
source = asusbat.patch
sha256sums = SKIP
sha256sums = 64f1f80187b5ace438cf9fd6afba89e0bad35c1e594beca111b3131df1e60000
sha256sums = 71caf34adf69e9e2567a38cfc951d1c60b13dbe87f58a9acfeb3fe48ffdc9d08
+ sha256sums = d590e751ab4cf424b78fd0d57e53d187f07401a68c8b468d17a5f39a337dacf0
sha256sums = 1f56a2466bd9b4477925682d8f944fabb38727140e246733214fe50aa326fc47
sha256sums = 93d24cbf50a3f9920bbdc2b07f7f665672089e2d7eda897ffba0587d6cf9ab51
diff --git a/PKGBUILD b/PKGBUILD
index 01bc1d7f3952..c7e2c84454ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgbase=linux-amd
_srcname=linux
gitver=v5.7.11
pkgver=5.7.v.11
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://www.kernel.org/"
license=('GPL2')
@@ -19,6 +19,8 @@ source=('git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git'
'config.x86_64'
# standard config files for mkinitcpio ramdisk
"${pkgbase}.preset"
+ # linux package install directives for pacman
+ 'linux.install'
# patch from our gentoo overlords
'5013_enable-cpu-optimizations-for-gcc10.patch'
# asusbat patch is back!
@@ -29,6 +31,8 @@ sha256sums=('SKIP'
'64f1f80187b5ace438cf9fd6afba89e0bad35c1e594beca111b3131df1e60000'
#.preset file
'71caf34adf69e9e2567a38cfc951d1c60b13dbe87f58a9acfeb3fe48ffdc9d08'
+ #linux install file
+ 'd590e751ab4cf424b78fd0d57e53d187f07401a68c8b468d17a5f39a337dacf0'
#gentoopatch
'1f56a2466bd9b4477925682d8f944fabb38727140e246733214fe50aa326fc47'
#asusbat.patch
@@ -231,7 +235,9 @@ _package-headers() {
done
# remove unneeded architectures
- rm -rf "${pkgdir}"/usr/lib/modules/${_kernver}/build/arch/{alpha,arc,arm,arm26,arm64,avr32,blackfin,c6x,cris,frv,h8300,hexagon,ia64,m32r,m68k,m68knommu,metag,mips,microblaze,mn10300,openrisc,parisc,powerpc,ppc,s390,score,sh,sh64,sparc,sparc64,tile,unicore32,um,v850,xtensa}
+ while read modarch; do
+ rm -rf $modarch
+ done <<< $(find "${pkgdir}"/usr/lib/modules/${_kernver}/build/arch/ -maxdepth 1 -mindepth 1 -type d | grep -v /x86$)
#Fix missing vdso files after overhaul
cp -r "include/vdso/" "${pkgdir}/usr/lib/modules/${_kernver}/build/include/"