summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
-rw-r--r--config.x86_643
-rw-r--r--more-uarches-for-kernel-5.8+.patch18
4 files changed, 23 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad4fb231e14c..e4307344c80a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-amd-znver2
- pkgver = 5.13.v.12
- pkgrel = 2
+ pkgver = 5.13.v.13
+ pkgrel = 1
url = https://www.kernel.org/
arch = x86_64
license = GPL2
@@ -14,16 +14,16 @@ pkgbase = linux-amd-znver2
makedepends = lzop
makedepends = gcc>=9.1
options = !strip
- source = git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git#tag=v5.13.12
+ source = git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git#tag=v5.13.13
source = config.x86_64
source = linux-amd-znver2.preset
source = linux.install
- source = https://raw.githubusercontent.com/graysky2/kernel_compiler_patch/20210817/more-uarches-for-kernel-5.8+.patch
+ source = https://raw.githubusercontent.com/graysky2/kernel_compiler_patch/20210818/more-uarches-for-kernel-5.8+.patch
sha256sums = SKIP
- sha256sums = 0b1154abe839708bd11195e5287e45326524d7317545e1819232cce040dfcc75
+ sha256sums = 3f7c4b295bf69c69b6968afaca6ef0551d324c77adaff6651ba52255f469490a
sha256sums = 60c6ba602443e94a9eba3aeee9d194027d69bffaa428c6d055348ebf03681b5c
sha256sums = d590e751ab4cf424b78fd0d57e53d187f07401a68c8b468d17a5f39a337dacf0
- sha256sums = d5c1e9f1bc33231f67a402ef192f0115f1a15bd1e4c35099138ee72e5d6ac682
+ sha256sums = 09945620d24a83608a66b1104477a1c1073701ac04b7aeae2f7819a2bf185c85
pkgname = linux-amd-znver2
pkgdesc = Linux kernel aimed at the znver2 AMD Ryzen CPU based hardware
diff --git a/PKGBUILD b/PKGBUILD
index 9a8ae5829e1f..9cd3085dd260 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
pkgbase=linux-amd-znver2
_srcname=linux
-gitver=v5.13.12
-patchver=20210817
-pkgver=5.13.v.12
-pkgrel=2
+gitver=v5.13.13
+patchver=20210818
+pkgver=5.13.v.13
+pkgrel=1
arch=('x86_64')
url="https://www.kernel.org/"
license=('GPL2')
@@ -24,13 +24,13 @@ source=("git+https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git#ta
)
sha256sums=('SKIP'
#config.x86_64
- '0b1154abe839708bd11195e5287e45326524d7317545e1819232cce040dfcc75'
+ '3f7c4b295bf69c69b6968afaca6ef0551d324c77adaff6651ba52255f469490a'
#.preset file
'60c6ba602443e94a9eba3aeee9d194027d69bffaa428c6d055348ebf03681b5c'
#linux install file
'd590e751ab4cf424b78fd0d57e53d187f07401a68c8b468d17a5f39a337dacf0'
#grayskypatch
- 'd5c1e9f1bc33231f67a402ef192f0115f1a15bd1e4c35099138ee72e5d6ac682'
+ '09945620d24a83608a66b1104477a1c1073701ac04b7aeae2f7819a2bf185c85'
)
_kernelname=${pkgbase#linux}
diff --git a/config.x86_64 b/config.x86_64
index ed26c3120d25..913b79f84299 100644
--- a/config.x86_64
+++ b/config.x86_64
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.13.12 Kernel Configuration
+# Linux/x86 5.13.13 Kernel Configuration
#
CONFIG_CC_VERSION_TEXT="gcc (GCC) 11.1.0"
CONFIG_CC_IS_GCC=y
@@ -9309,6 +9309,7 @@ CONFIG_FUNCTION_GRAPH_TRACER=y
CONFIG_DYNAMIC_FTRACE=y
CONFIG_DYNAMIC_FTRACE_WITH_REGS=y
CONFIG_DYNAMIC_FTRACE_WITH_DIRECT_CALLS=y
+CONFIG_DYNAMIC_FTRACE_WITH_ARGS=y
CONFIG_FUNCTION_PROFILER=y
CONFIG_STACK_TRACER=y
# CONFIG_IRQSOFF_TRACER is not set
diff --git a/more-uarches-for-kernel-5.8+.patch b/more-uarches-for-kernel-5.8+.patch
index 9226a6555c70..e37528f9e1b6 100644
--- a/more-uarches-for-kernel-5.8+.patch
+++ b/more-uarches-for-kernel-5.8+.patch
@@ -219,7 +219,7 @@ index 814fe0d349b0..8acf6519d279 100644
+
+config MZEN3
+ bool "AMD Zen 3"
-+ depends on ( CC_IS_GCC && GCC_VERSION >= 100300 ) || ( CC_IS_CLANG && CLANG_VERSION >= 120000 )
++ depends on (CC_IS_GCC && GCC_VERSION >= 100300) || (CC_IS_CLANG && CLANG_VERSION >= 120000)
+ help
+ Select this for AMD Family 19h Zen 3 processors.
+
@@ -378,7 +378,7 @@ index 814fe0d349b0..8acf6519d279 100644
+
+config MCOOPERLAKE
+ bool "Intel Cooper Lake"
-+ depends on ( CC_IS_GCC && GCC_VERSION > 100100 ) || ( CC_IS_CLANG && CLANG_VERSION >= 100000 )
++ depends on (CC_IS_GCC && GCC_VERSION > 100100) || (CC_IS_CLANG && CLANG_VERSION >= 100000)
+ select X86_P6_NOP
+ help
+
@@ -388,7 +388,7 @@ index 814fe0d349b0..8acf6519d279 100644
+
+config MTIGERLAKE
+ bool "Intel Tiger Lake"
-+ depends on ( CC_IS_GCC && GCC_VERSION > 100100 ) || ( CC_IS_CLANG && CLANG_VERSION >= 100000 )
++ depends on (CC_IS_GCC && GCC_VERSION > 100100) || (CC_IS_CLANG && CLANG_VERSION >= 100000)
+ select X86_P6_NOP
+ help
+
@@ -398,7 +398,7 @@ index 814fe0d349b0..8acf6519d279 100644
+
+config MSAPPHIRERAPIDS
+ bool "Intel Sapphire Rapids"
-+ depends on ( CC_IS_GCC && GCC_VERSION > 110000 ) || ( CC_IS_CLANG && CLANG_VERSION >= 120000 )
++ depends on (CC_IS_GCC && GCC_VERSION > 110000) || (CC_IS_CLANG && CLANG_VERSION >= 120000)
+ select X86_P6_NOP
+ help
+
@@ -408,7 +408,7 @@ index 814fe0d349b0..8acf6519d279 100644
+
+config MROCKETLAKE
+ bool "Intel Rocket Lake"
-+ depends on ( CC_IS_GCC && GCC_VERSION > 110000 ) || ( CC_IS_CLANG && CLANG_VERSION >= 120000 )
++ depends on (CC_IS_GCC && GCC_VERSION > 110000) || (CC_IS_CLANG && CLANG_VERSION >= 120000)
+ select X86_P6_NOP
+ help
+
@@ -418,7 +418,7 @@ index 814fe0d349b0..8acf6519d279 100644
+
+config MALDERLAKE
+ bool "Intel Alder Lake"
-+ depends on ( CC_IS_GCC && GCC_VERSION > 110000 ) || ( CC_IS_CLANG && CLANG_VERSION >= 120000 )
++ depends on (CC_IS_GCC && GCC_VERSION > 110000) || (CC_IS_CLANG && CLANG_VERSION >= 120000)
+ select X86_P6_NOP
+ help
+
@@ -435,7 +435,7 @@ index 814fe0d349b0..8acf6519d279 100644
+config GENERIC_CPU2
+ bool "Generic-x86-64-v2"
-+ depends on ( CC_IS_GCC && GCC_VERSION > 110000 ) || ( CC_IS_CLANG && CLANG_VERSION >= 120000 )
++ depends on (CC_IS_GCC && GCC_VERSION > 110000) || (CC_IS_CLANG && CLANG_VERSION >= 120000)
+ depends on X86_64
+ help
+ Generic x86-64 CPU.
@@ -443,7 +443,7 @@ index 814fe0d349b0..8acf6519d279 100644
+
+config GENERIC_CPU3
+ bool "Generic-x86-64-v3"
-+ depends on ( CC_IS_GCC && GCC_VERSION > 110000 ) || ( CC_IS_CLANG && CLANG_VERSION >= 120000 )
++ depends on (CC_IS_GCC && GCC_VERSION > 110000) || (CC_IS_CLANG && CLANG_VERSION >= 120000)
+ depends on X86_64
+ help
+ Generic x86-64-v3 CPU with v3 instructions.
@@ -451,7 +451,7 @@ index 814fe0d349b0..8acf6519d279 100644
+
+config GENERIC_CPU4
+ bool "Generic-x86-64-v4"
-+ depends on ( CC_IS_GCC && GCC_VERSION > 110000 ) || ( CC_IS_CLANG && CLANG_VERSION >= 120000 )
++ depends on (CC_IS_GCC && GCC_VERSION > 110000) || (CC_IS_CLANG && CLANG_VERSION >= 120000)
+ depends on X86_64
+ help
+ Generic x86-64 CPU with v4 instructions.