summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f591b453f204..67024cf28644 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-amd-znver2
pkgver = 6.2.v.3
- pkgrel = 1
+ pkgrel = 2
url = https://www.kernel.org/
arch = x86_64
license = GPL2
diff --git a/PKGBUILD b/PKGBUILD
index 2ae15e5ee224..c669e333c643 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ gitver=v6.2.3
patchver=20230105
patchname=more-uarches-for-kernel-5.17+.patch
pkgver=6.2.v.3
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://www.kernel.org/"
license=('GPL2')
@@ -52,13 +52,16 @@ prepare() {
# don't run depmod on 'make install'. We'll do this ourselves in packaging
sed -i '2iexit 0' scripts/depmod.sh
- # Implement all packaged patches.
- msg2 "Implementing custom kernel patches"
+ # Implement all packaged patches and reverts.
+ msg2 "Implementing custom kernel patches/reverts"
while read patch; do
echo "Applying $patch"
git apply $patch || exit 2
done <<< $(ls ../*.patch)
+ git revert bfe46d2efe46c5c952f982e2ca94fe2ec5e58e2a --no-edit
+ git revert 57a425badc05c2e87e9f25713e5c3c0298e4202c --no-edit
+
# get kernel version
msg2 "Preparing kernel"
yes "" | make prepare