summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-x.SRCINFO12
-rwxr-xr-xPKGBUILD18
2 files changed, 7 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index efa2416e875a..bc5636e9bd55 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = linux-bcachefs-git
- pkgver = 5.0.7.arch1
+ pkgver = 5.0.8.arch1
pkgrel = 1
url = https://github.com/koverstreet/bcachefs
arch = x86_64
license = GPL2
makedepends = bc
makedepends = git
- makedepends = graphviz
makedepends = inetutils
makedepends = kmod
makedepends = libelf
- makedepends = python-sphinx
makedepends = xmlto
options = !strip
source = git+https://github.com/koverstreet/bcachefs#branch=master
@@ -41,11 +39,11 @@ pkgname = linux-bcachefs-git
pkgname = linux-bcachefs-git-headers
pkgdesc = Header files and scripts for building modules for Linux-bcachefs-git kernel
- provides = linux-bcachefs-git-headers=5.0.7.arch1
- provides = linux-headers=5.0.7.arch1
+ provides = linux-bcachefs-git-headers=5.0.8.arch1
+ provides = linux-headers=5.0.8.arch1
pkgname = linux-bcachefs-git-docs
pkgdesc = Kernel hackers manual - HTML documentation that comes with the Linux-bcachefs-git kernel
- provides = linux-bcachefs-git-docs=5.0.7.arch1
- provides = linux-docs=5.0.7.arch1
+ provides = linux-bcachefs-git-docs=5.0.8.arch1
+ provides = linux-docs=5.0.8.arch1
diff --git a/PKGBUILD b/PKGBUILD
index b3b9d6c43d71..32521ad61ee7 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -59,7 +59,7 @@ _subarch=
_localmodcfg=
pkgbase=linux-bcachefs-git
-_srcver_tag_arch=5.0.7-arch1
+_srcver_tag_arch=5.0.8-arch1
pkgver=${_srcver_tag_arch//-/.}
pkgrel=1
arch=(x86_64)
@@ -68,11 +68,9 @@ license=(GPL2)
makedepends=(
bc
git
- graphviz
inetutils
kmod
libelf
- python-sphinx
xmlto
)
options=('!strip')
@@ -166,7 +164,7 @@ prepare() {
build() {
cd ${_reponame}
- make bzImage modules htmldocs
+ make bzImage modules
}
_package() {
@@ -330,18 +328,6 @@ _package-docs() {
mkdir -p "$builddir"
cp -t "$builddir" -a Documentation
- msg2 "Removing doctrees..."
- rm -r "$builddir/Documentation/output/.doctrees"
-
- msg2 "Moving HTML docs..."
- local src dst
- while read -rd '' src; do
- dst="$builddir/Documentation/${src#$builddir/Documentation/output/}"
- mkdir -p "${dst%/*}"
- mv "$src" "$dst"
- rmdir -p --ignore-fail-on-non-empty "${src%/*}"
- done < <(find "$builddir/Documentation/output" -type f -print0)
-
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/share/doc"
ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"