summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD19
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16727b7b5907..3b05d33b9b35 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri Nov 23 11:47:32 UTC 2018
+# Fri Nov 23 19:52:57 UTC 2018
pkgbase = linux-ck
pkgver = 4.19.4
pkgrel = 1
diff --git a/PKGBUILD b/PKGBUILD
index f3591a358107..e284747ac2f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -57,7 +57,9 @@ _NUMAdisable=y
# that you currently have probed in your system VASTLY reducing the number of
# modules built and the build time to do it.
#
-# WARNING - ALL modules must be probed BEFORE you begin making the pkg!
+# WARNING - ALL modules must be probed or loaded via a config file BEFORE you
+# begin making the pkg unless you're running modprobed-db (AUR) and building
+# this with makepkg as the user who is keeping the database.
#
# To keep track of which modules are needed for your specific system/hardware,
# give module_db script a try: https://aur.archlinux.org/packages/modprobed-db
@@ -161,16 +163,15 @@ prepare() {
### Optionally load needed modules for the make localmodconfig
# See https://aur.archlinux.org/packages/modprobed-db
if [ -n "$_localmodcfg" ]; then
- msg "If you have modprobed-db installed, running it in recall mode now"
- if [ -e /usr/bin/modprobed-db ]; then
- [[ -x /usr/bin/sudo ]] || {
- echo "Cannot call modprobe with sudo. Install sudo and configure it to work with this user."
- exit 1; }
- sudo /usr/bin/modprobed-db recall
+ if [ -f $HOME/.config/modprobed.db ]; then
+ msg "Found a modprobed-db database for Steven Rostedt's make localmodconfig"
+ make LSMOD=$HOME/.config/modprobed.db localmodconfig
+ else
+ msg "Running Steven Rostedt's make localmodconfig now"
+ make localmodconfig
fi
- msg "Running Steven Rostedt's make localmodconfig now"
- make localmodconfig
fi
+
# do not run `make olddefconfig` as it sets default options
yes "" | make config >/dev/null