summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cbb26e16c24f..cf59b3371809 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = linux-intel-undervolt-gui-bin
pkgdesc = GUI frontend for undervolting intel CPUs on Linux (binary release)
pkgver = 1.2.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/lukechadwick/linux-intel-undervolt-gui
arch = x86_64
license = MIT
- depends = gconf
depends = libappindicator-gtk3
depends = libnotify
depends = libxss
depends = libxtst
- depends = nss
depends = python-undervolt
provides = linux-intel-undervolt-gui
conflicts = linux-intel-undervolt-gui
source = https://github.com/lukechadwick/linux-intel-undervolt-gui/releases/download/1.2.0/linux-intel-undervolt-gui-1.2.0.x86_64.rpm
+ source = https://github.com/lukechadwick/linux-intel-undervolt-gui/raw/1.2.0/LICENSE
sha256sums = bd238a33f0d6e7c19174e4c63585bae5110b9496adb42915118cc95c27862c58
+ sha256sums = SKIP
pkgname = linux-intel-undervolt-gui-bin
diff --git a/PKGBUILD b/PKGBUILD
index c5b7958cbbea..9fcd19aa9f1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,17 @@ _pkgname=linux-intel-undervolt-gui
pkgname=$_pkgname-bin
pkgdesc="GUI frontend for undervolting intel CPUs on Linux (binary release)"
pkgver=1.2.0
-pkgrel=2
+pkgrel=3
arch=('x86_64')
url="https://github.com/lukechadwick/linux-intel-undervolt-gui"
license=('MIT')
-depends=('gconf' 'libappindicator-gtk3' 'libnotify' 'libxss' 'libxtst' 'nss' 'python-undervolt')
+depends=('libappindicator-gtk3' 'libnotify' 'libxss' 'libxtst' 'python-undervolt')
conflicts=($_pkgname)
provides=($_pkgname)
-source=("$url/releases/download/$pkgver/linux-intel-undervolt-gui-$pkgver.x86_64.rpm")
-sha256sums=('bd238a33f0d6e7c19174e4c63585bae5110b9496adb42915118cc95c27862c58')
+source=("$url/releases/download/$pkgver/linux-intel-undervolt-gui-$pkgver.x86_64.rpm"
+ "https://github.com/lukechadwick/linux-intel-undervolt-gui/raw/$pkgver/LICENSE")
+sha256sums=('bd238a33f0d6e7c19174e4c63585bae5110b9496adb42915118cc95c27862c58'
+ 'SKIP')
package() {
# Create folders
@@ -23,7 +25,8 @@ package() {
install -Dm644 usr/share/icons/hicolor/${i}x${i}/apps/$_pkgname.png "$pkgdir"/usr/share/icons/hicolor/${i}x${i}/apps/$_pkgname.png
done
install -Dm644 usr/share/applications/$_pkgname.desktop -t "$pkgdir/usr/share/applications"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
cp -r opt/UndervoltGUI "$pkgdir/opt/UndervoltGUI"
ln -s /opt/UndervoltGUI/linux-intel-undervolt-gui -t "$pkgdir/usr/bin"
- ln -fs /usr/lib/python3.10/site-packages/undervolt.py -t "$pkgdir/opt/UndervoltGUI/resources/app/extras"
+ ln -fs /usr/lib/python3.11/site-packages/undervolt.py -t "$pkgdir/opt/UndervoltGUI/resources/app/extras"
}