summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c91f0ae8ba4..73d3e822b01d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -71,3 +71,6 @@ pkgname = linux-mainline-bootsplash
pkgname = linux-mainline-bootsplash-headers
pkgdesc = Headers and scripts for building modules for the Linux Mainline - with bootsplash support kernel
+pkgname = linux-mainline-bootsplash-docs
+ pkgdesc = Documentation for the Linux Mainline - with bootsplash support kernel
+
diff --git a/PKGBUILD b/PKGBUILD
index 4eacdc8f5edb..52e7595f61bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -88,7 +88,7 @@ prepare() {
echo "Setting config..."
cp ../config .config
- make localmodconfig
+ make olddefconfig
make -s kernelrelease > version
echo "Prepared $pkgbase version $(<version)"
@@ -97,6 +97,7 @@ prepare() {
build() {
cd $_srcname
make all
+ make htmldocs
}
_package() {
@@ -223,7 +224,7 @@ _package-docs() {
ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
}
-pkgname=("$pkgbase" "$pkgbase-headers")
+pkgname=("$pkgbase" "$pkgbase-headers" "$pkgbase-docs")
for _p in "${pkgname[@]}"; do
eval "package_$_p() {
$(declare -f "_package${_p#$pkgbase}")