summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-x.SRCINFO12
-rwxr-xr-xPKGBUILD21
2 files changed, 23 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5cab0d6cd9a6..07e5c0036ccc 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-test-project
pkgdesc = Collection of tools for testing the Linux kernel and related features
- pkgver = 20230127
- pkgrel = 1
+ pkgver = 20230929
+ pkgrel = 2
url = https://linux-test-project.github.io/
arch = i686
arch = x86_64
@@ -13,8 +13,12 @@ pkgbase = linux-test-project
depends = perl
depends = python
depends = numactl
+ depends = keyutils
+ depends = openssl
+ depends = glibc
options = !lto
- source = https://github.com/linux-test-project/ltp/releases/download/20230127/ltp-full-20230127.tar.xz
- sha256sums = 254412a52c7238f35a247337da186f485e76fb64c6549ed849b3442fc7a417ef
+ options = !strip
+ source = https://github.com/linux-test-project/ltp/releases/download/20230929/ltp-full-20230929.tar.xz
+ sha256sums = eb161ff8f1966a1f3428fd4561eb20ebb9f83b7519e35cc12fc66bcfa7983b6b
pkgname = linux-test-project
diff --git a/PKGBUILD b/PKGBUILD
index a80d7ea3d234..ba221f107ecc 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,32 @@
# Contributor: Lukas Jirkovsky <l.jirkovsky@gmail.com>
pkgname=linux-test-project
-pkgver=20230127
-pkgrel=1
+pkgver=20230929
+pkgrel=2
pkgdesc="Collection of tools for testing the Linux kernel and related features"
arch=(i686 x86_64)
license=(GPL2)
url="https://linux-test-project.github.io/"
-depends=(acl bash gawk libcap perl python numactl)
+depends=(acl bash gawk libcap perl python numactl keyutils openssl glibc)
+options=(!lto !strip)
source=("https://github.com/linux-test-project/ltp/releases/download/${pkgver}/ltp-full-${pkgver}.tar.xz")
-sha256sums=('254412a52c7238f35a247337da186f485e76fb64c6549ed849b3442fc7a417ef')
-options=(!lto)
+sha256sums=('eb161ff8f1966a1f3428fd4561eb20ebb9f83b7519e35cc12fc66bcfa7983b6b')
build() {
cd "${srcdir}/ltp-full-${pkgver}"
- ./configure --prefix=/usr/share --mandir=/usr/share/man --with-bash
+ ./configure \
+ --prefix=/usr/share \
+ --mandir=/usr/share/man \
+ --with-bash
+
make
}
+check() {
+ cd "${srcdir}/ltp-full-${pkgver}"
+ make test
+}
+
package() {
cd "${srcdir}/ltp-full-${pkgver}"
make DESTDIR="$pkgdir" install